]> code.ossystems Code Review - openembedded-core.git/commitdiff
bison: fix Argument list too long error
authorLee Chee Yang <chee.yang.lee@intel.com>
Mon, 11 May 2020 10:57:02 +0000 (18:57 +0800)
committerSteve Sakoman <steve@sakoman.com>
Tue, 14 Jul 2020 03:16:12 +0000 (17:16 -1000)
fix Argument list too long error when len(TMPDIR) = 410

Signed-off-by: Lee Chee Yang <chee.yang.lee@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 73f05ba58dcee57e25712f9aee97535d9a32c982)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-devtools/bison/bison_3.5.3.bb

index 36c29fe4dfa012293beaeb1d021ae6ebf04f65a1..e6c169e9dbbf2a8c34a856447060d0c7b690b11d 100644 (file)
@@ -28,7 +28,7 @@ EXTRA_OEMAKE_append = " -l"
 inherit autotools gettext texinfo
 
 # The automatic m4 path detection gets confused, so force the right value
-acpaths = "-I ${S}/m4"
+acpaths = "-I ./m4"
 
 do_compile_prepend() {
        for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done