]> code.ossystems Code Review - openembedded-core.git/commitdiff
adt: Update to svn r596 to fix symbolic link issues
authorLiping Ke <liping.ke@intel.com>
Mon, 7 Mar 2011 05:10:42 +0000 (13:10 +0800)
committerSaul Wold <sgw@linux.intel.com>
Tue, 8 Mar 2011 00:22:35 +0000 (16:22 -0800)
See the longlinksfix patch for details but symlinks over 100 chars long
were broken in sdk tarballs and its due to problems in the inbuilt tar in
libbb in opkg. svn r596 has already fixed the problem.

Signed-off-by: Liping Ke <liping.ke@intel.com>
meta/conf/distro/include/poky-default-revisions.inc
meta/recipes-devtools/installer/adt-installer/adt_installer
meta/recipes-devtools/installer/adt-installer_1.0.bb

index 5045c9e10ed49b9d08633795eb9fb7e2bf8aebd4..36202a1194a5fd22258284808d9c7a5568b6b4d8 100644 (file)
@@ -140,6 +140,7 @@ OPKGSRCREV = "596"
 SRCREV_pn-opkg ??= "${OPKGSRCREV}"
 SRCREV_pn-opkg-native ??= "${OPKGSRCREV}"
 SRCREV_pn-opkg-nativesdk ??= "${OPKGSRCREV}"
+SRCREV_pn-adt-installer ??= "${OPKGSRCREV}"
 SRCREV_pn-opkg-nogpg ??= "${OPKGSRCREV}"
 SRCREV_pn-opkg-nogpg-native ??= "${OPKGSRCREV}"
 SRCREV_pn-opkg-nogpg-nativesdk ??= "${OPKGSRCREV}"
index 2448d2b9f719032a5cae165f63a417c053dbfab1..b1b497002eabfaa60fe29054ef1bb17431c92d56 100755 (executable)
@@ -170,7 +170,7 @@ if [ ! -x "$LOCAL_OPKG_LOC/bin/opkg-cl" ]; then
   check_result
 
   echo_info "Configure opkg ...\n"
-  ./configure --prefix=$parent_folder/$LOCAL_OPKG_LOC --with-opkglibdir=$OPKG_LIBDIR --disable-curl --disable-ssl-curl --disable-gpg --disable-shave >> $parent_folder/$YOCTOADT_INSTALL_LOG_FILE
+  ./autogen.sh --prefix=$parent_folder/$LOCAL_OPKG_LOC --with-opkglibdir=$OPKG_LIBDIR --disable-curl --disable-ssl-curl --disable-gpg --disable-shave >> $parent_folder/$YOCTOADT_INSTALL_LOG_FILE
   check_result
 
   echo_info "Make opkg ...\n"
index e8659716c8e279fc5c27da255ecdbeedbf43cad7..50290f9ffd1fb06e9167978b9cbff88460ca0fdb 100644 (file)
@@ -39,7 +39,8 @@ YOCTOADT_VERSION = "${SDK_VERSION}"
 
 inherit deploy
 
-SRC_URI = "http://opkg.googlecode.com/files/opkg-0.1.8.tar.gz \
+PV = "0.1.8+svnr${SRCPV}"
+SRC_URI = "svn://opkg.googlecode.com/svn;module=trunk;proto=http \
            file://adt_installer \
            file://scripts/adt_installer_internal \
            file://scripts/util \
@@ -49,8 +50,6 @@ SRC_URI = "http://opkg.googlecode.com/files/opkg-0.1.8.tar.gz \
            file://opkg/conf/opkg-sdk-x86_64.conf \
            file://opkg/conf/opkg-sdk-i686.conf \
          "
-SRC_URI[md5sum] = "c714ce0e4863bf1315e3b6913ffe3299"
-SRC_URI[sha256sum] = "ff94bf30bd662d49c4b5057e3a0818d062731adaa555d59abd677ec32a3c1c60"
 
 fakeroot do_deploy () {
        cd ${WORKDIR}
@@ -59,7 +58,8 @@ fakeroot do_deploy () {
        rm -rf ${ADT_DIR}
        mkdir -p ${ADT_DIR}/opkg/build
        cp -r opkg ${ADT_DIR}/
-       cp -r opkg-0.1.8 ${ADT_DIR}/opkg/build/
+       cp -r trunk ${ADT_DIR}/opkg/build/
+       mv ${ADT_DIR}/opkg/build/trunk ${ADT_DIR}/opkg/build/opkg-svn
        cp -r scripts ${ADT_DIR}/
        cp adt_installer ${ADT_DIR}
        cp adt_installer.conf ${ADT_DIR}