]> code.ossystems Code Review - openembedded-core.git/commitdiff
groff: Fix sstate relocation issue
authorSaul Wold <sgw@linux.intel.com>
Sun, 4 Sep 2011 03:51:02 +0000 (20:51 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 5 Sep 2011 16:53:02 +0000 (17:53 +0100)
[YOCTO #1439]

This fixes a problem where the native groff has a path hard coded into
it, therefor add a wrapper to set the command line with the correct
paths for fonts and tmac directories.

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/groff/groff_1.20.1.bb

index 7085911002f14aa94550fac849f349b423b11b48..6cb72bf1175951c97fee9627d4af56a74a6512e8 100644 (file)
@@ -4,7 +4,7 @@ formatting commands and produces formatted output."
 SECTION = "base"
 HOMEPAGE = "ftp://ftp.gnu.org/gnu/groff/"
 LICENSE = "GPLv2"
-PR = "r0"
+PR = "r1"
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
 
@@ -34,4 +34,11 @@ do_configure_prepend() {
        fi
 }
 
+do_install_append_virtclass-native() {
+       create_cmdline_wrapper ${D}/${bindir}/groff \
+               -F${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/font \
+               -M${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/tmac
+}
+
+
 BBCLASSEXTEND = "native"