]> code.ossystems Code Review - openembedded-core.git/commitdiff
libjpeg-turbo: Build reproducibly
authorJoshua Watt <jpewhacker@gmail.com>
Mon, 9 Dec 2019 04:03:12 +0000 (22:03 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 15 Dec 2019 09:04:38 +0000 (09:04 +0000)
Configures the options passed to nasm to remove build paths in the
generated object files.

Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/jpeg/libjpeg-turbo_2.0.3.bb

index 1cf854de62526a8119387b731dab9b9fa2881f62..32d3bd93b185fe7e8792bf5f0e60152fdc023f62 100644 (file)
@@ -29,6 +29,8 @@ RCONFLICTS_${PN} += "jpeg"
 
 inherit cmake pkgconfig
 
+export NASMENV = "--debug-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}"
+
 # Add nasm-native dependency consistently for all build arches is hard
 EXTRA_OECMAKE_append_class-native = " -DWITH_SIMD=False"
 EXTRA_OECMAKE_append_class-nativesdk = " -DWITH_SIMD=False"