]> code.ossystems Code Review - openembedded-core.git/commitdiff
latencytop: upgrade from 0.4 to the latest version 0.5
authorDexuan Cui <dexuan.cui@intel.com>
Tue, 20 Jul 2010 11:07:52 +0000 (19:07 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 21 Jul 2010 15:00:55 +0000 (16:00 +0100)
Add BUGTRACKER
Rebase the patch latencytop-makefile.patch and update the patch folder's name
Add LIC_FILES_CHKSUM
Reset PR to "r0"

Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
meta-moblin/packages/latencytop/latencytop-0.4/latencytop-makefile.patch [deleted file]
meta-moblin/packages/latencytop/latencytop-0.5/latencytop-makefile.patch [new file with mode: 0644]
meta-moblin/packages/latencytop/latencytop_0.5.bb [moved from meta-moblin/packages/latencytop/latencytop_0.4.bb with 65% similarity]

diff --git a/meta-moblin/packages/latencytop/latencytop-0.4/latencytop-makefile.patch b/meta-moblin/packages/latencytop/latencytop-0.4/latencytop-makefile.patch
deleted file mode 100644 (file)
index 8840d38..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
---- a/Makefile 2008-11-14 22:55:51.000000000 +0800
-+++ b/Makefile 2008-11-14 23:00:51.000000000 +0800
-@@ -1,7 +1,8 @@
- DESTDIR =
- SBINDIR = /usr/sbin
- XCFLAGS = -W `pkg-config --cflags glib-2.0` -D_FORTIFY_SOURCE=2 -Wno-sign-compare 
--LDF = -Wl,--as-needed `pkg-config --libs glib-2.0`   -lncursesw 
-+LDF = -Wl,--as-needed `pkg-config --libs glib-2.0`   -lncurses 
-+CC ?= gcc
- #
- # The w in -lncursesw is not a typo; it is the wide-character version
-@@ -14,10 +15,10 @@ LDF = -Wl,--as-needed `pkg-config --libs
- # We write explicity this "implicit rule"
- %.o : %.c
--      gcc -c $(CFLAGS) $(XCFLAGS) $< -o $@
-+      $(CC) -c $(CFLAGS) $(XCFLAGS) $< -o $@
- latencytop: latencytop.o display.o latencytop.h translate.o Makefile
--      gcc $(CFLAGS) latencytop.o display.o translate.o $(LDF) -o latencytop 
-+      $(CC) $(CFLAGS) latencytop.o display.o translate.o $(LDF) -o latencytop 
- clean:
-@@ -25,5 +26,6 @@ clean:
- install: latencytop
-       mkdir -p $(DESTDIR)/usr/share/latencytop
-+      mkdir -p $(DESTDIR)$(SBINDIR)
-       install -m 0644 latencytop.trans $(DESTDIR)/usr/share/latencytop/latencytop.trans
-       install -m 0755 latencytop $(DESTDIR)$(SBINDIR)/
diff --git a/meta-moblin/packages/latencytop/latencytop-0.5/latencytop-makefile.patch b/meta-moblin/packages/latencytop/latencytop-0.5/latencytop-makefile.patch
new file mode 100644 (file)
index 0000000..b979f57
--- /dev/null
@@ -0,0 +1,32 @@
+--- a/Makefile 2010-07-20 18:51:32.000000000 +0800
++++ b/Makefile 2010-07-20 18:54:54.000000000 +0800
+@@ -4,7 +4,8 @@
+ DESTDIR =
+ SBINDIR = /usr/sbin
+ XCFLAGS = -W  -g `pkg-config --cflags glib-2.0` -D_FORTIFY_SOURCE=2 -Wno-sign-compare
+-LDF = -Wl,--as-needed `pkg-config --libs glib-2.0`   -lncursesw 
++LDF = -Wl,--as-needed `pkg-config --libs glib-2.0`   -lncurses
++CC ?= gcc
+ OBJS= latencytop.o text_display.o translate.o fsync.o
+@@ -26,16 +27,17 @@
+ # We write explicity this "implicit rule"
+ %.o : %.c
+-      gcc -c $(CFLAGS) $(XCFLAGS) $< -o $@
++      $(CC) -c $(CFLAGS) $(XCFLAGS) $< -o $@
+ latencytop:  $(OBJS) latencytop.h Makefile
+-      gcc $(CFLAGS) $(OBJS) $(LDF) -o latencytop 
++      $(CC) $(CFLAGS) $(OBJS) $(LDF) -o latencytop
+ clean:
+       rm -f *~ latencytop DEADJOE *.o
+ install: latencytop
+       mkdir -p $(DESTDIR)/usr/share/latencytop
++      mkdir -p $(DESTDIR)/$(SBINDIR)
+       install -m 0644 latencytop.trans $(DESTDIR)/usr/share/latencytop/latencytop.trans
+       install -m 0644 *.png $(DESTDIR)/usr/share/latencytop/
+       install -m 0755 latencytop $(DESTDIR)$(SBINDIR)/
similarity index 65%
rename from meta-moblin/packages/latencytop/latencytop_0.4.bb
rename to meta-moblin/packages/latencytop/latencytop_0.5.bb
index 706d0817b564faaf52fc0020ffe1276531e6d7a6..2deb7303b0741c6784e3763280e8825c147296f5 100644 (file)
@@ -1,11 +1,16 @@
 DESCRIPTION = "LatencyTOP, a Linux tool measuring and fixing latency"
 HOMEPAGE = "http://www.latencytop.org/"
+BUGTRACKER = "n/a"
+
 LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://latencytop.c;endline=23;md5=ee9ea9b1415356e5734adad4a87dc7fa"
+
 DEPENDS = "virtual/libintl ncurses glib-2.0"
-PR = "r1"
+
+PR = "r0"
 
 SRC_URI = "http://www.latencytop.org/download/latencytop-${PV}.tar.gz \
-          file://latencytop-makefile.patch;patch=1"
+            file://latencytop-makefile.patch"
 
 CFLAGS += "${LDFLAGS}"