]> code.ossystems Code Review - openembedded-core.git/commitdiff
rngd: fix --debug to also filter syslog() calls
authorYann Dirson <yann@blade-group.com>
Fri, 9 Oct 2020 16:20:30 +0000 (18:20 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 10 Oct 2020 12:37:44 +0000 (13:37 +0100)
Debug logs were only controlled by --debug flag while in --foreground mode.
In --daemon mode (the default for us) /var/log/message got stuffed with
details of entropy pool refilling, which is useless in production, and
hamful when log rotation then gets rid of the more useful logs.

This change makes the two modes consistently only produce debug logs when
--debug is specified.

Signed-off-by: Yann Dirson <yann@blade-group.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/rng-tools/rng-tools/0001-rngd-fix-debug-to-also-filter-syslog-calls.patch [new file with mode: 0644]
meta/recipes-support/rng-tools/rng-tools_6.10.bb

diff --git a/meta/recipes-support/rng-tools/rng-tools/0001-rngd-fix-debug-to-also-filter-syslog-calls.patch b/meta/recipes-support/rng-tools/rng-tools/0001-rngd-fix-debug-to-also-filter-syslog-calls.patch
new file mode 100644 (file)
index 0000000..0733378
--- /dev/null
@@ -0,0 +1,46 @@
+From 213a869e8315ead2c739acfcbde712358a842dee Mon Sep 17 00:00:00 2001
+From: Yann Dirson <yann@blade-group.com>
+Date: Fri, 9 Oct 2020 15:12:26 +0200
+Subject: [PATCH] rngd: fix --debug to also filter syslog() calls
+
+Debug logs were only controlled by --debug flag while in --foreground
+mode.  In --daemon mode /var/log/message got stuffed with details of
+entropy pool refilling, which is useless in production, and hamful
+when log rotation then gets rid of the more useful logs.  This is
+especially true for embedded systems.
+
+This change makes the two modes consistently only produce debug logs when
+--debug is specified.
+
+Upstream-Status: Backport [213a869e8315ead2c739acfcbde712358a842dee]
+
+Signed-off-by: Yann Dirson <yann@blade-group.com>
+---
+ rngd.h | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/rngd.h b/rngd.h
+index 901b6f1..a79ea0f 100644
+--- a/rngd.h
++++ b/rngd.h
+@@ -166,13 +166,13 @@ extern bool quiet;
+ #define message(priority,fmt,args...) do { \
+       if (quiet) \
+               break;\
++      if (arguments->debug == false && LOG_PRI(priority) == LOG_DEBUG) \
++              break;\
+       if (am_daemon) { \
+               syslog((priority), fmt, ##args); \
+       } else if (!msg_squash) { \
+-              if ((LOG_PRI(priority) != LOG_DEBUG) || (arguments->debug == true)) {\
+-                      fprintf(stderr, fmt, ##args); \
+-                      fflush(stderr); \
+-              } \
++              fprintf(stderr, fmt, ##args); \
++              fflush(stderr); \
+       } \
+ } while (0)
+-- 
+2.28.0
+
index 3f9720e406fbb6a7fbf000e80418e3807a31e09f..40ec5ad671df26c035e7548928f98ae2efa174f3 100644 (file)
@@ -12,6 +12,7 @@ SRC_URI = "\
     git://github.com/nhorman/rng-tools.git \
     file://a4b6d9ce64f132e463b9091d0536913ddaf11516.patch \
     file://dab16a5fd4efde8ef569b358e19b1fcbc7d0d938.patch \
+    file://0001-rngd-fix-debug-to-also-filter-syslog-calls.patch \
     file://init \
     file://default \
     file://rngd.service \