]> code.ossystems Code Review - openembedded-core.git/commitdiff
pciutils: add PACKAGECONFIG for 'hwdb'
authorChen Qi <Qi.Chen@windriver.com>
Fri, 26 Dec 2014 09:35:31 +0000 (17:35 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 27 Dec 2014 09:15:54 +0000 (09:15 +0000)
Add PACKAGECONFIG for 'hwdb' to fix the following QA warning.
WARNING: QA Issue: libpci rdepends on libudev, but it isn't a build dependency? [build-deps]
WARNING: QA Issue: pciutils rdepends on libudev, but it isn't a build dependency? [build-deps]

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-bsp/pciutils/pciutils_3.3.0.bb

index 71f7e04d62093873b0299afc3aa377a1a0afc93a..f544919e8ebdfd3ca35078a857e99138171df749 100644 (file)
@@ -18,13 +18,18 @@ SRC_URI[sha256sum] = "413395d4bdc66fdedd6c993ed9083d1dd73812bf2a679d320f73de35c7
 
 inherit multilib_header
 
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[hwdb] = "HWDB=yes,HWDB=no,udev"
+
 PCI_CONF_FLAG = "ZLIB=yes DNS=yes SHARED=yes"
 
 # see configure.patch
 do_configure () {
        (
          cd lib && \
-         ${PCI_CONF_FLAG} ./configure ${PV} ${datadir} ${TARGET_OS} ${TARGET_ARCH}
+         # EXTRA_OECONF for this recipe could only possibly contain 'HWDB=yes/no', so we put it
+         # before ./configure
+         ${PCI_CONF_FLAG} ${EXTRA_OECONF} ./configure ${PV} ${datadir} ${TARGET_OS} ${TARGET_ARCH}
        )
 }