]> code.ossystems Code Review - openembedded-core.git/commitdiff
weston: Fix bug causing the xwayland package to always be included
authorTom Hochstein <tom.hochstein@nxp.com>
Thu, 9 Jun 2016 23:09:19 +0000 (18:09 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 12 Jun 2016 22:46:42 +0000 (23:46 +0100)
The xwayland package was always being built due to its inclusion in
PACKAGE_BEFORE_PN. The effect was masked by making the RDEPENDS conditional.

Now we make the PACKAGE_BEFORE_PN inclusion conditional and restore
the xwayland RDEPENDS to unconditional.

Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-graphics/wayland/weston_1.10.0.bb

index 37a4839e0fb810fb383b9f5f9e78debad235c672..6b934e2232216a0a32c7e0a9f3ecb2ddcab02965 100644 (file)
@@ -100,14 +100,14 @@ do_install_append() {
        fi
 }
 
-PACKAGE_BEFORE_PN += "${PN}-xwayland"
+PACKAGE_BEFORE_PN += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', '${PN}-xwayland', '', d)}"
 PACKAGES += "${PN}-examples"
 
 FILES_${PN} = "${bindir}/weston ${bindir}/weston-terminal ${bindir}/weston-info ${bindir}/weston-launch ${bindir}/wcap-decode ${libexecdir} ${libdir}/${BPN}/*.so ${datadir}"
 FILES_${PN}-examples = "${bindir}/*"
 
 FILES_${PN}-xwayland = "${libdir}/${BPN}/xwayland.so"
-RDEPENDS_${PN}-xwayland += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'xserver-xorg-xwayland', '', d)}"
+RDEPENDS_${PN}-xwayland += "xserver-xorg-xwayland"
 
 RDEPENDS_${PN} += "xkeyboard-config"
 RRECOMMENDS_${PN} = "liberation-fonts"