]> code.ossystems Code Review - openembedded-core.git/commitdiff
unzip: Convert to use BBCLASSEXTEND
authorRichard Purdie <rpurdie@linux.intel.com>
Wed, 4 Nov 2009 15:52:03 +0000 (15:52 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 13 Nov 2009 12:15:23 +0000 (12:15 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/unzip/unzip-native_552.bb [deleted file]
meta/packages/unzip/unzip_552.bb

diff --git a/meta/packages/unzip/unzip-native_552.bb b/meta/packages/unzip/unzip-native_552.bb
deleted file mode 100644 (file)
index 1d4b18c..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-SECTION = "console/utils"
-inherit native
-require unzip_${PV}.bb
-
-do_stage() {
-       install -d ${STAGING_BINDIR}
-       install unzip ${STAGING_BINDIR}
-}
index 2f06e1b1c699d31faa838420ddf0465e4aa9dd2a..84e4fd4a73f010b5e117730734151e30ca3a1df5 100644 (file)
@@ -7,6 +7,7 @@ SRC_URI = "http://ftp.info-zip.org/pub/infozip/src/unzip${PV}.tar.gz"
 S = "${WORKDIR}/unzip-5.52"
 
 export LD = "${CC}"
+LD_virtclass-native = "${CC}"
 
 do_compile() {
         oe_runmake -f unix/Makefile generic
@@ -18,4 +19,5 @@ do_install() {
        mv ${D}${prefix}/man/* ${D}${mandir}
 }
 
-
+BBCLASSEXTEND = "native"
+NATIVE_INSTALL_WORKS = "1"