]> code.ossystems Code Review - openembedded-core.git/commitdiff
gobject-introspection: fix floating dep on python-mako
authorChristopher Larson <chris_larson@mentor.com>
Thu, 21 Apr 2016 12:29:35 +0000 (17:59 +0530)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 29 Apr 2016 06:34:10 +0000 (07:34 +0100)
This was resulting in non-deterministic builds where g-ir-doc-tool may or may
not exist depending on whether python-mako was built previously. Add
a PACKAGECONFIG so the dependency is explicit.

Signed-off-by: Sujith H <sujith.h@gmail.com>
Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Signed-off-by: Sujith Haridasan <Sujith_Haridasan@mentor.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-gnome/gobject-introspection/gobject-introspection_1.46.0.bb

index 9b16147da3e6df6c4bd6af41dcab4bf798211c34..67891a2ad996fa52f42ada5410cd5d98e26d0292 100644 (file)
@@ -108,6 +108,8 @@ EXTRA_OECONF_class-target += "--enable-host-gi \
                               ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '--enable-introspection-data', '--disable-introspection-data', d)} \
                              "
 
+PACKAGECONFIG ?= ""
+PACKAGECONFIG[doctool] = "--enable-doctool,--disable-doctool,python-mako,"
 
 do_compile_prepend_class-target() {
         # This prevents g-ir-scanner from writing cache data to $HOME