]> code.ossystems Code Review - openembedded-core.git/commitdiff
libical: refresh patches
authorRoss Burton <ross.burton@intel.com>
Thu, 8 Mar 2018 18:17:28 +0000 (20:17 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 9 Mar 2018 17:15:59 +0000 (09:15 -0800)
The patch tool will apply patches by default with "fuzz", which is where if the
hunk context isn't present but what is there is close enough, it will force the
patch in.

Whilst this is useful when there's just whitespace changes, when applied to
source it is possible for a patch applied with fuzz to produce broken code which
still compiles (see #10450).  This is obviously bad.

We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For
that to be realistic the existing patches with fuzz need to be rebased and
reviewed.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-support/libical/libical/Remove-cmake-check-for-Perl.patch

index c5c0cb076e6ae60ce65bb13d314509609371e0a6..b50f50e7017f4c258936802de0bb80e9b5a8fe71 100644 (file)
@@ -14,11 +14,11 @@ Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
  CMakeLists.txt | 3 +--
  1 file changed, 1 insertion(+), 2 deletions(-)
 
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index d5aad80..5cc9863 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -91,8 +91,7 @@ if(SHARED_ONLY)
+Index: libical-2.0.0/CMakeLists.txt
+===================================================================
+--- libical-2.0.0.orig/CMakeLists.txt
++++ libical-2.0.0/CMakeLists.txt
+@@ -116,8 +116,7 @@ if(SHARED_ONLY)
    set(LIBRARY_TYPE SHARED)
  endif()
  
@@ -26,8 +26,5 @@ index d5aad80..5cc9863 100644
 -find_package(Perl REQUIRED)
 +set(PERL_EXECUTABLE perl)
  
- # MSVC specific definitions
- if(WIN32)
--- 
-2.1.4
-
+ # Ensure finding 64bit libs when using 64-bit compilers
+ if(CMAKE_CL_64)