]> code.ossystems Code Review - openembedded-core.git/commitdiff
syslinux: Convert to BBCLASSEXTEND, clean up recipe and staging function
authorRichard Purdie <rpurdie@linux.intel.com>
Thu, 25 Mar 2010 14:08:12 +0000 (14:08 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 25 Mar 2010 14:08:12 +0000 (14:08 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/syslinux/syslinux-installer-native_3.36.bb [deleted file]
meta/packages/syslinux/syslinux_3.36.bb

diff --git a/meta/packages/syslinux/syslinux-installer-native_3.36.bb b/meta/packages/syslinux/syslinux-installer-native_3.36.bb
deleted file mode 100644 (file)
index c304a2d..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright (C) 2004-2006, Advanced Micro Devices, Inc.  All Rights Reserved
-# Released under the MIT license (see packages/COPYING)
-
-DESCRIPTION = "A multi-purpose linux bootloader"
-HOMEPAGE = "http://syslinux.zytor.com/"
-LICENSE = "GPL"
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 "
-DEPENDS = "nasm-native"
-
-S = "${WORKDIR}/syslinux-${PV}"
-STAGE_TEMP = "${WORKDIR}/stage_temp"
-
-inherit native
-
-do_compile() {
-       oe_runmake installer
-}
-
-NATIVE_INSTALL_WORKS = "1"
-do_install() {
-       install -d ${STAGE_TEMP}
-       oe_runmake install INSTALLROOT="${STAGE_TEMP}"
-
-       install -d ${D}${bindir}/
-       install -m 755 ${STAGE_TEMP}/usr/bin/syslinux ${D}${bindir}/
-       install -m 755 ${STAGE_TEMP}/sbin/extlinux ${D}${bindir}/
-}
index 8db2055dc976afeeba921f8408546b666f1a5a66..5073ac358a8e11b818915457add4adeef72924d0 100644 (file)
@@ -2,32 +2,29 @@ DESCRIPTION = "A multi-purpose linux bootloader"
 HOMEPAGE = "http://syslinux.zytor.com/"
 LICENSE = "GPL"
 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2"
-PR = "r1"
+PR = "r3"
 
 # If you really want to run syslinux, you need mtools.  We just want the
 # ldlinux.* stuff for now, so skip mtools-native
 DEPENDS = "nasm-native"
 
-S = "${WORKDIR}/syslinux-${PV}"
-
 do_configure() {
        sed -i ${S}/Makefile ${S}/*/Makefile -e 's/\(CC[\t ]*\)=/\1?=/'
 }
 
-STAGE_TEMP = "${WORKDIR}/stage_temp"
-
 COMPATIBLE_HOST = '(x86_64|i.86.*)-(linux|freebsd.*)'
 
+do_compile_virtclass-native () {
+       oe_runmake installer
+}
+
+NATIVE_INSTALL_WORKS = "1"
 do_install() {
-       install -d ${STAGE_TEMP}
-       oe_runmake install INSTALLROOT="${STAGE_TEMP}"
-       
-       # When building media, the syslinux binary isn't nearly as useful
-       # as the DOS data files, so we copy those into a special location
-       # for usage during a image build stage
-           
-       install -d ${D}${datadir}/syslinux/
-       install -m 0644 ${STAGE_TEMP}/usr/lib/syslinux/isolinux.bin ${D}${datadir}/syslinux/isolinux.bin
-       install -m 644 ${S}/ldlinux.sys ${D}${datadir}/syslinux/ldlinux.sys
-       install -m 644 ${S}/ldlinux.bss ${D}${datadir}/syslinux/ldlinux.bss
+       oe_runmake install INSTALLROOT="${D}"
+
+       install -d ${D}${libdir}/syslinux/
+       install -m 644 ${S}/ldlinux.sys ${D}${libdir}/syslinux/
+       install -m 644 ${S}/ldlinux.bss ${D}${libdir}/syslinux/
 }
+
+BBCLASSEXTEND = "native"