]> code.ossystems Code Review - openembedded-core.git/commitdiff
libart_lgpl: Allow art_config.h to be generated at compile time
authorNathan Rossi <nathan.rossi@xilinx.com>
Wed, 29 Apr 2015 07:44:34 +0000 (17:44 +1000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 3 May 2015 10:39:48 +0000 (11:39 +0100)
* Remove patch that prevents the Makefile from generating the
  art_config.h file
* Remove pre-generated art_config.h for various architecture
* Add a do_compile prepend to remove the art_config.h that is provided
  in the source so that the compilation will regenerate the file

Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
17 files changed:
meta/recipes-gnome/gnome/libart-lgpl/Makefile.am.patch [deleted file]
meta/recipes-gnome/gnome/libart-lgpl/aarch64/art_config.h [deleted file]
meta/recipes-gnome/gnome/libart-lgpl/aarch64be/art_config.h [deleted file]
meta/recipes-gnome/gnome/libart-lgpl/aarch64be_32/art_config.h [deleted file]
meta/recipes-gnome/gnome/libart-lgpl/arm/art_config.h [deleted file]
meta/recipes-gnome/gnome/libart-lgpl/armeb/art_config.h [deleted file]
meta/recipes-gnome/gnome/libart-lgpl/i386/art_config.h [deleted file]
meta/recipes-gnome/gnome/libart-lgpl/i586/art_config.h [deleted file]
meta/recipes-gnome/gnome/libart-lgpl/i686/art_config.h [deleted file]
meta/recipes-gnome/gnome/libart-lgpl/mips/art_config.h [deleted file]
meta/recipes-gnome/gnome/libart-lgpl/mips64/art_config.h [deleted file]
meta/recipes-gnome/gnome/libart-lgpl/mips64el/art_config.h [deleted file]
meta/recipes-gnome/gnome/libart-lgpl/mipsel/art_config.h [deleted file]
meta/recipes-gnome/gnome/libart-lgpl/powerpc/art_config.h [deleted file]
meta/recipes-gnome/gnome/libart-lgpl/powerpc64/art_config.h [deleted file]
meta/recipes-gnome/gnome/libart-lgpl/x86_64/art_config.h [deleted file]
meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb

diff --git a/meta/recipes-gnome/gnome/libart-lgpl/Makefile.am.patch b/meta/recipes-gnome/gnome/libart-lgpl/Makefile.am.patch
deleted file mode 100644 (file)
index 190ba96..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-Upstream-Status: Inappropriate [configuration]
-
-Index: libart_lgpl-2.3.21/Makefile.am
-===================================================================
---- libart_lgpl-2.3.21.orig/Makefile.am        2009-04-18 05:29:25.000000000 -0700
-+++ libart_lgpl-2.3.21/Makefile.am     2010-11-23 23:12:32.445450075 -0800
-@@ -7,8 +7,8 @@
- BUILT_SOURCES = art_config.h
--art_config.h:
--      ./gen_art_config.sh > art_config.h
-+#art_config.h:
-+#     ./gen_art_config.sh > art_config.h
- EXTRA_DIST =                  \
-       libart.def              \
diff --git a/meta/recipes-gnome/gnome/libart-lgpl/aarch64/art_config.h b/meta/recipes-gnome/gnome/libart-lgpl/aarch64/art_config.h
deleted file mode 100644 (file)
index 500ffc3..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-/* Automatically generated by gen_art_config.c */
-
-#define ART_SIZEOF_CHAR 1
-#define ART_SIZEOF_SHORT 2
-#define ART_SIZEOF_INT 4
-#define ART_SIZEOF_LONG 8
-
-typedef unsigned char art_u8;
-typedef unsigned short art_u16;
-typedef unsigned int art_u32;
diff --git a/meta/recipes-gnome/gnome/libart-lgpl/aarch64be/art_config.h b/meta/recipes-gnome/gnome/libart-lgpl/aarch64be/art_config.h
deleted file mode 100644 (file)
index 500ffc3..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-/* Automatically generated by gen_art_config.c */
-
-#define ART_SIZEOF_CHAR 1
-#define ART_SIZEOF_SHORT 2
-#define ART_SIZEOF_INT 4
-#define ART_SIZEOF_LONG 8
-
-typedef unsigned char art_u8;
-typedef unsigned short art_u16;
-typedef unsigned int art_u32;
diff --git a/meta/recipes-gnome/gnome/libart-lgpl/aarch64be_32/art_config.h b/meta/recipes-gnome/gnome/libart-lgpl/aarch64be_32/art_config.h
deleted file mode 100644 (file)
index b0e74ad..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-/* Automatically generated by gen_art_config.c */
-
-#define ART_SIZEOF_CHAR 1
-#define ART_SIZEOF_SHORT 2
-#define ART_SIZEOF_INT 4
-#define ART_SIZEOF_LONG 4
-
-typedef unsigned char art_u8;
-typedef unsigned short art_u16;
-typedef unsigned int art_u32;
diff --git a/meta/recipes-gnome/gnome/libart-lgpl/arm/art_config.h b/meta/recipes-gnome/gnome/libart-lgpl/arm/art_config.h
deleted file mode 100644 (file)
index b0e74ad..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-/* Automatically generated by gen_art_config.c */
-
-#define ART_SIZEOF_CHAR 1
-#define ART_SIZEOF_SHORT 2
-#define ART_SIZEOF_INT 4
-#define ART_SIZEOF_LONG 4
-
-typedef unsigned char art_u8;
-typedef unsigned short art_u16;
-typedef unsigned int art_u32;
diff --git a/meta/recipes-gnome/gnome/libart-lgpl/armeb/art_config.h b/meta/recipes-gnome/gnome/libart-lgpl/armeb/art_config.h
deleted file mode 100644 (file)
index b0e74ad..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-/* Automatically generated by gen_art_config.c */
-
-#define ART_SIZEOF_CHAR 1
-#define ART_SIZEOF_SHORT 2
-#define ART_SIZEOF_INT 4
-#define ART_SIZEOF_LONG 4
-
-typedef unsigned char art_u8;
-typedef unsigned short art_u16;
-typedef unsigned int art_u32;
diff --git a/meta/recipes-gnome/gnome/libart-lgpl/i386/art_config.h b/meta/recipes-gnome/gnome/libart-lgpl/i386/art_config.h
deleted file mode 100644 (file)
index b0e74ad..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-/* Automatically generated by gen_art_config.c */
-
-#define ART_SIZEOF_CHAR 1
-#define ART_SIZEOF_SHORT 2
-#define ART_SIZEOF_INT 4
-#define ART_SIZEOF_LONG 4
-
-typedef unsigned char art_u8;
-typedef unsigned short art_u16;
-typedef unsigned int art_u32;
diff --git a/meta/recipes-gnome/gnome/libart-lgpl/i586/art_config.h b/meta/recipes-gnome/gnome/libart-lgpl/i586/art_config.h
deleted file mode 100644 (file)
index b0e74ad..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-/* Automatically generated by gen_art_config.c */
-
-#define ART_SIZEOF_CHAR 1
-#define ART_SIZEOF_SHORT 2
-#define ART_SIZEOF_INT 4
-#define ART_SIZEOF_LONG 4
-
-typedef unsigned char art_u8;
-typedef unsigned short art_u16;
-typedef unsigned int art_u32;
diff --git a/meta/recipes-gnome/gnome/libart-lgpl/i686/art_config.h b/meta/recipes-gnome/gnome/libart-lgpl/i686/art_config.h
deleted file mode 100644 (file)
index b0e74ad..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-/* Automatically generated by gen_art_config.c */
-
-#define ART_SIZEOF_CHAR 1
-#define ART_SIZEOF_SHORT 2
-#define ART_SIZEOF_INT 4
-#define ART_SIZEOF_LONG 4
-
-typedef unsigned char art_u8;
-typedef unsigned short art_u16;
-typedef unsigned int art_u32;
diff --git a/meta/recipes-gnome/gnome/libart-lgpl/mips/art_config.h b/meta/recipes-gnome/gnome/libart-lgpl/mips/art_config.h
deleted file mode 100644 (file)
index b0e74ad..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-/* Automatically generated by gen_art_config.c */
-
-#define ART_SIZEOF_CHAR 1
-#define ART_SIZEOF_SHORT 2
-#define ART_SIZEOF_INT 4
-#define ART_SIZEOF_LONG 4
-
-typedef unsigned char art_u8;
-typedef unsigned short art_u16;
-typedef unsigned int art_u32;
diff --git a/meta/recipes-gnome/gnome/libart-lgpl/mips64/art_config.h b/meta/recipes-gnome/gnome/libart-lgpl/mips64/art_config.h
deleted file mode 100644 (file)
index d10cd95..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-/* Automatically generated by gen_art_config */
-
-#define ART_SIZEOF_CHAR 1
-#define ART_SIZEOF_SHORT 2
-#define ART_SIZEOF_INT 4
-#define ART_SIZEOF_LONG 8
-
-typedef unsigned char art_u8;
-typedef unsigned short art_u16;
-typedef unsigned int art_u32;
diff --git a/meta/recipes-gnome/gnome/libart-lgpl/mips64el/art_config.h b/meta/recipes-gnome/gnome/libart-lgpl/mips64el/art_config.h
deleted file mode 100644 (file)
index d10cd95..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-/* Automatically generated by gen_art_config */
-
-#define ART_SIZEOF_CHAR 1
-#define ART_SIZEOF_SHORT 2
-#define ART_SIZEOF_INT 4
-#define ART_SIZEOF_LONG 8
-
-typedef unsigned char art_u8;
-typedef unsigned short art_u16;
-typedef unsigned int art_u32;
diff --git a/meta/recipes-gnome/gnome/libart-lgpl/mipsel/art_config.h b/meta/recipes-gnome/gnome/libart-lgpl/mipsel/art_config.h
deleted file mode 100644 (file)
index b0e74ad..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-/* Automatically generated by gen_art_config.c */
-
-#define ART_SIZEOF_CHAR 1
-#define ART_SIZEOF_SHORT 2
-#define ART_SIZEOF_INT 4
-#define ART_SIZEOF_LONG 4
-
-typedef unsigned char art_u8;
-typedef unsigned short art_u16;
-typedef unsigned int art_u32;
diff --git a/meta/recipes-gnome/gnome/libart-lgpl/powerpc/art_config.h b/meta/recipes-gnome/gnome/libart-lgpl/powerpc/art_config.h
deleted file mode 100644 (file)
index b0e74ad..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-/* Automatically generated by gen_art_config.c */
-
-#define ART_SIZEOF_CHAR 1
-#define ART_SIZEOF_SHORT 2
-#define ART_SIZEOF_INT 4
-#define ART_SIZEOF_LONG 4
-
-typedef unsigned char art_u8;
-typedef unsigned short art_u16;
-typedef unsigned int art_u32;
diff --git a/meta/recipes-gnome/gnome/libart-lgpl/powerpc64/art_config.h b/meta/recipes-gnome/gnome/libart-lgpl/powerpc64/art_config.h
deleted file mode 100644 (file)
index 500ffc3..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-/* Automatically generated by gen_art_config.c */
-
-#define ART_SIZEOF_CHAR 1
-#define ART_SIZEOF_SHORT 2
-#define ART_SIZEOF_INT 4
-#define ART_SIZEOF_LONG 8
-
-typedef unsigned char art_u8;
-typedef unsigned short art_u16;
-typedef unsigned int art_u32;
diff --git a/meta/recipes-gnome/gnome/libart-lgpl/x86_64/art_config.h b/meta/recipes-gnome/gnome/libart-lgpl/x86_64/art_config.h
deleted file mode 100644 (file)
index 500ffc3..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-/* Automatically generated by gen_art_config.c */
-
-#define ART_SIZEOF_CHAR 1
-#define ART_SIZEOF_SHORT 2
-#define ART_SIZEOF_INT 4
-#define ART_SIZEOF_LONG 8
-
-typedef unsigned char art_u8;
-typedef unsigned short art_u16;
-typedef unsigned int art_u32;
index 4966ea4c7a9613b150f525c70233f11b0e3085b7..138461684c21a8966ab4471ff6cc9767f9ac5f75 100644 (file)
@@ -4,12 +4,8 @@ LICENSE = "LGPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
 PR = "r2"
 
-ART_CONFIG = "${HOST_ARCH}/art_config.h"
-
 # can't use gnome.oeclass due to _ in filename
-SRC_URI = "${GNOME_MIRROR}/libart_lgpl/2.3/libart_lgpl-${PV}.tar.bz2 \
-       file://${ART_CONFIG} \
-       file://Makefile.am.patch"
+SRC_URI = "${GNOME_MIRROR}/libart_lgpl/2.3/libart_lgpl-${PV}.tar.bz2"
 
 SRC_URI[md5sum] = "08559ff3c67fd95d57b0c5e91a6b4302"
 SRC_URI[sha256sum] = "fdc11e74c10fc9ffe4188537e2b370c0abacca7d89021d4d303afdf7fd7476fa"
@@ -23,6 +19,8 @@ FILES_${PN}-dev += "${bindir}/libart2-config"
 
 S = "${WORKDIR}/libart_lgpl-${PV}"
 
-do_configure_prepend() {
-       cp ${WORKDIR}/${ART_CONFIG} ${S}/art_config.h
+do_compile_prepend() {
+       # enforce regeneration of art_config.h
+       rm ${S}/art_config.h
 }
+