]> code.ossystems Code Review - openembedded-core.git/commitdiff
alsa-lib: 1.1.6 -> 1.1.8
authorTanu Kaskinen <tanuk@iki.fi>
Thu, 21 Feb 2019 20:13:03 +0000 (22:13 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 25 Feb 2019 10:42:56 +0000 (10:42 +0000)
Changelogs:
http://alsa-project.org/main/index.php/Changes_v1.1.6_v1.1.7
http://alsa-project.org/main/index.php/Changes_v1.1.7_v1.1.8

One significant change was that the search path of add-on configuration
files was changed from /usr/share/alsa/alsa.conf.d to /etc/alsa/conf.d.
Packages that install such files should still use the /usr/share
location, though. Symlinks need to be created from /etc to /usr/share.
The rationale for using /etc is that the system administrator can better
control the configuration that way, and the rationale for installing
files under /usr/share is that configuration snippets that are installed
by packages are not meant to be directly edited by the administrator.

alsa-plugins had to be modified to add symlinks for the configuration
snippets that it installs. I also added FILES_${PN} = "", because the
alsa-plugins package is supposed to be empty, but also because for some
reason that I don't understand the symlinks would otherwise go to the
alsa-plugins package rather than alsa-plugins-pulseaudio-conf.

SRC_URI was changed to a more reliable source (at least currently the
ftp server is flaky).

Signed-off-by: Tanu Kaskinen <tanuk@iki.fi>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-multimedia/alsa/alsa-lib_1.1.8.bb [moved from meta/recipes-multimedia/alsa/alsa-lib_1.1.6.bb with 83% similarity]
meta/recipes-multimedia/alsa/alsa-plugins_1.1.6.bb

similarity index 83%
rename from meta/recipes-multimedia/alsa/alsa-lib_1.1.6.bb
rename to meta/recipes-multimedia/alsa/alsa-lib_1.1.8.bb
index 25e7a3c6b7255073ee3d580c78499c81b5f89072..76cc9627e5b3c1628fc1977c67ac0ee8ceb6e520 100644 (file)
@@ -7,9 +7,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7 \
                     file://src/socket.c;md5=dd1bc7f44872690224d89c1a9806e495;beginline=1;endline=26 \
                     "
 
-SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/${BP}.tar.bz2"
-SRC_URI[md5sum] = "2f981a8f7897c59ec2ddc44916d33788"
-SRC_URI[sha256sum] = "5f2cd274b272cae0d0d111e8a9e363f08783329157e8dd68b3de0c096de6d724"
+SRC_URI = "https://www.alsa-project.org/files/pub/lib/${BP}.tar.bz2"
+SRC_URI[md5sum] = "0eec0d657a07927795809c8f87fb76ca"
+SRC_URI[sha256sum] = "3cdc3a93a6427a26d8efab4ada2152e64dd89140d981f6ffa003e85be707aedf"
 
 inherit autotools pkgconfig
 
index 7ede8be98a2d6b1c8d68cb596495482aeb950f63..ee06191ea938b01b24e3caa88f039788d33de5b8 100644 (file)
@@ -47,14 +47,23 @@ PACKAGES_DYNAMIC = "^libasound-module-.*"
 
 # The alsa-plugins package doesn't itself contain anything, it just depends on
 # all built plugins.
+FILES_${PN} = ""
 ALLOW_EMPTY_${PN} = "1"
 
 do_install_append() {
        rm ${D}${libdir}/alsa-lib/*.la
 
-       # We use the example as is, so just drop the .example suffix.
        if [ "${@bb.utils.contains('PACKAGECONFIG', 'pulseaudio', 'yes', 'no', d)}" = "yes" ]; then
+               # We use the example as is, so just drop the .example suffix.
                mv ${D}${datadir}/alsa/alsa.conf.d/99-pulseaudio-default.conf.example ${D}${datadir}/alsa/alsa.conf.d/99-pulseaudio-default.conf
+
+               # The conf.d files are installed in datadir, but alsa-lib
+               # searches for conf.d files only in sysconfdir. Distributions
+               # are expected to create symlinks in sysconfdir, so that's what
+               # we do here.
+               mkdir -p ${D}${sysconfdir}/alsa/conf.d
+               ln -s ${datadir}/alsa/alsa.conf.d/50-pulseaudio.conf ${D}${sysconfdir}/alsa/conf.d/50-pulseaudio.conf
+               ln -s ${datadir}/alsa/alsa.conf.d/99-pulseaudio-default.conf ${D}${sysconfdir}/alsa/conf.d/99-pulseaudio-default.conf
        fi
 }
 
@@ -94,6 +103,8 @@ INSANE_SKIP_${MLPREFIX}libasound-module-rate-speexrate = "dev-so"
 FILES_${PN}-pulseaudio-conf += "\
         ${datadir}/alsa/alsa.conf.d/50-pulseaudio.conf \
         ${datadir}/alsa/alsa.conf.d/99-pulseaudio-default.conf \
+        ${sysconfdir}/alsa/conf.d/50-pulseaudio.conf \
+        ${sysconfdir}/alsa/conf.d/99-pulseaudio-default.conf \
 "
 
 RDEPENDS_${PN}-pulseaudio-conf += "\