]> code.ossystems Code Review - openembedded-core.git/commitdiff
qmmp: add QT app qmmp, an QT audio-player
authorYu Ke <ke.yu@intel.com>
Wed, 25 Aug 2010 03:13:00 +0000 (11:13 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 27 Aug 2010 12:29:52 +0000 (13:29 +0100)
Add qmmp from qt-apps.org to validate and demo qt library. qmmp is an audio-player, written with help of Qt library

Signed-off-by: Yu Ke <ke.yu@intel.com>
meta-lsb/packages/qt-apps/qmmp_0.4.1.bb [new file with mode: 0644]

diff --git a/meta-lsb/packages/qt-apps/qmmp_0.4.1.bb b/meta-lsb/packages/qt-apps/qmmp_0.4.1.bb
new file mode 100644 (file)
index 0000000..5f971e8
--- /dev/null
@@ -0,0 +1,32 @@
+DESCRIPTION = "Qmmp (Qt-based Multimedia Player) is an audio-player, written with help of Qt library"
+HOMEPAGE = "http://qmmp.ylsoftware.com"
+LICENSE = "GPLv2"
+SECTION = "multimedia"
+
+DEPENDS = "qt4-x11-free"
+RDEPENDS = "qt4-x11-free libmad libvorbis libogg taglib alsa-lib curl"
+
+SRC_URI = "http://qmmp.ylsoftware.com/files/qmmp-0.4.1.tar.bz2"
+
+PARALLEL_MAKE = ""
+
+inherit qmake2 pkgconfig
+
+do_configure_prepend() {
+       # fix qt4 lrelease name
+       sed -i -e 's/lrelease-qt4/lrelease4/' ${S}/qmmp.pro
+
+       # disable the unsupported plugin
+       for plugin in sndfile wavpack ; do
+               sed -i -e "s/$plugin//" ${S}/src/plugins/Input/Input.pro
+       done
+       sed -i -e 's/mms//' ${S}/src/plugins/Transports/Transports.pro
+       sed -i -e 's/srconverter//' ${S}/src/plugins/Effect/Effect.pro
+
+       sed -i -e 's/^CONFIG/#CONFIG/' ${S}/qmmp.pri
+       sed -i -e 's/CONFIG += WITH_ENCA/#CONFIG += WITH_ENCA/' ${S}/qmmp.pri
+}
+
+do_install() {
+       oe_runmake INSTALL_ROOT=${D} install
+}