]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/kernel-meta: ktype refactoring: move DEBUG_KERNEL, EXPERT and EMBEDDED
authorBruce Ashfield <bruce.ashfield@windriver.com>
Fri, 4 Mar 2016 18:21:16 +0000 (13:21 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 9 Mar 2016 16:54:37 +0000 (16:54 +0000)
Integrating the folliwing patch series from Cal:

  This patch series refactors the ktypes so that base and standard ktypes
  do not enable EMBEDDED, EXPERT, or DEBUG_KERNEL. The reason this
  decision was made is because production platforms likely do not want
  DEBUG_KERNEL enabled, and EMBEDDED selects EXPERT which selects
  DEBUG_KERNEL.

  A new ktype called "developer" was also created. This ktype
  enables the options now missing from standard and base, making it easy
  to maintain the functionality of a BSP through simply swapping the ktype
  from standard to developer. The preempt-rt ktype is now based off of
  developer in order to maintain its functionality.

  The new standard ktype does not include EMBEDDED, EXPERT, or
  DEBUG_KERNEL. Without DEBUG_KERNEL it loses a number of debug features
  that are selected by default. Without EXPERT it gains RFKILL_INPUT and
  DEBUG_MEMORY_INIT, while losing VMSPLIT_3G. These are only available to
  configure with CONFIG_EXPERT=y and default to EXPERT or !EXPERT. Not
  selecting EMBEDDED has no apparent impacts.

  Some coordination is required for this change, as existing BSPs WILL be
  affected, and will either need to accept the changes in the standard
  ktype or move to the developer ktype.

  California Sullivan (12):
    features/debug: add debug-kernel feature
    ktypes: add developer ktype
    ktypes/base: Disable EMBEDDED and DEBUG_KERNEL
    CONFIG_PROCESSOR_SELECT: do not enable
    intel-common-drivers.scc: move profiling and latencytop to a new file
    romley.scc remove profiling and latencytop features
    bsp/intel-common: add intel-core* developer BSPs
    preempt-rt.scc: include developer ktype instead of standard
    intel-common: add intel-developer-drivers.scc to preempt-rt BSPs
    CONFIG_I2C_I801: set option to yes in intel-core* BSPs
    bsp: add developer common-pc BSPs
    bsp: remove profiling and latencytop from non-developer common-pc BSPs

Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
meta/recipes-kernel/linux/linux-yocto_4.4.bb

index 7251c07fce812b1ec68318f6a3e96e89b6263995..41619d7296a362bfc9d39e68210bf33caaf0be1c 100644 (file)
@@ -3,7 +3,7 @@ KBRANCH ?= "standard/preempt-rt"
 require recipes-kernel/linux/linux-yocto.inc
 
 SRCREV_machine ?= "853991833cc5140ca25450e81bf6b822d537a6ac"
-SRCREV_meta ?= "8b6a7d80344837fd64163008521a31a6f891313e"
+SRCREV_meta ?= "da47accec6c17c22cecf064be1da29b5bf3d7583"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;branch=${KBRANCH};name=machine \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.4;destsuffix=${KMETA}"
index 0d35bc3ce8b0e478d2036033b9cf9fc67e9dd96c..5a0884a487061f0673473852b600c2e322fa6368 100644 (file)
@@ -10,7 +10,7 @@ KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
 SRCREV_machine ?= "ff4c4ef15b51f45b9106d71bf1f62fe7c02e63c2"
-SRCREV_meta ?= "8b6a7d80344837fd64163008521a31a6f891313e"
+SRCREV_meta ?= "da47accec6c17c22cecf064be1da29b5bf3d7583"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
index c5f160d78691c1c17c3332b7d27e61305cf77279..9c3fe7f1dedbfa7ad779ce916c6695f2b7a94983 100644 (file)
@@ -19,7 +19,7 @@ SRCREV_machine_qemux86 ?= "ff4c4ef15b51f45b9106d71bf1f62fe7c02e63c2"
 SRCREV_machine_qemux86-64 ?= "ff4c4ef15b51f45b9106d71bf1f62fe7c02e63c2"
 SRCREV_machine_qemumips64 ?= "8bbcb369cf605d1ada384f4b950da2abc5d1f4cc"
 SRCREV_machine ?= "ff4c4ef15b51f45b9106d71bf1f62fe7c02e63c2"
-SRCREV_meta ?= "8b6a7d80344837fd64163008521a31a6f891313e"
+SRCREV_meta ?= "da47accec6c17c22cecf064be1da29b5bf3d7583"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;name=machine;branch=${KBRANCH}; \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.4;destsuffix=${KMETA}"