]> code.ossystems Code Review - openembedded-core.git/commitdiff
sqlite3: upgrade to 3.6.23.1
authorYu Ke <ke.yu@intel.com>
Tue, 20 Jul 2010 08:26:40 +0000 (16:26 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 21 Jul 2010 15:01:00 +0000 (16:01 +0100)
also remove the cross-compile.patch and ldflags.patch,
since they are no longer used.

Signed-off-by: Yu Ke <ke.yu@intel.com>
meta/packages/sqlite/sqlite3.inc
meta/packages/sqlite/sqlite3/cross-compile.patch [deleted file]
meta/packages/sqlite/sqlite3/ldflags.patch [deleted file]
meta/packages/sqlite/sqlite3_3.6.23.1.bb [moved from meta/packages/sqlite/sqlite3_3.6.20.bb with 67% similarity]

index fc102c4b699e45841af8054bafe485a478dd0df7..11e901114a0d62afe63a6c56b28bbc0183e7c112 100644 (file)
@@ -1,11 +1,12 @@
 DESCRIPTION = "An Embeddable SQL Database Engine"
+HOMEPAGE = "http://www.sqlite.org"
 SECTION = "libs"
 PRIORITY = "optional"
 DEPENDS = "readline ncurses tcl-native"
 LICENSE = "PD"
 
 SRC_URI = "http://www.sqlite.org/sqlite-${PV}.tar.gz \
-          file://libtool.patch;patch=1"
+          file://libtool.patch"
 
 S = "${WORKDIR}/sqlite-${PV}"
 
diff --git a/meta/packages/sqlite/sqlite3/cross-compile.patch b/meta/packages/sqlite/sqlite3/cross-compile.patch
deleted file mode 100644 (file)
index 31d4f0d..0000000
+++ /dev/null
@@ -1,92 +0,0 @@
---- sqlite-3.3.7/configure.ac.orig     2006-08-21 00:20:50.000000000 +0200
-+++ sqlite-3.3.7/configure.ac  2006-08-21 00:22:35.000000000 +0200
-@@ -187,10 +187,11 @@
- default_build_cflags="-g"
- if test "$config_BUILD_CC" = ""; then
-   AC_PROG_CC
--  if test "$cross_compiling" = "yes"; then
--    AC_MSG_ERROR([unable to find a compiler for building build tools])
--  fi
--  BUILD_CC=$CC
-+#  if test "$cross_compiling" = "yes"; then
-+#    AC_MSG_ERROR([unable to find a compiler for building build tools])
-+#  fi
-+#  BUILD_CC=$CC
-+BUILD_CC=gcc
-   default_build_cflags=$CFLAGS
- else
-   BUILD_CC=$config_BUILD_CC
-@@ -238,6 +239,12 @@
-   TARGET_LINK=$config_TARGET_LINK
- fi
- AC_MSG_RESULT($TARGET_LINK)
-+if test "$config_TARGET_LFLAGS" != ""; then
-+  TARGET_LFLAGS=$config_TARGET_LFLAGS
-+  else
-+    TARGET_LFLAGS=$BUILD_LFLAGS
-+  fi
-+AC_MSG_RESULT($TARGET_LFLAGS)
- AC_MSG_CHECKING([switches on the target compiler])
- if test "$config_TARGET_TFLAGS" != ""; then
-   TARGET_TFLAGS=$config_TARGET_TFLAGS
-@@ -592,15 +599,7 @@
- # Figure out what C libraries are required to compile programs
- # that use "readline()" library.
- #
--if test "$config_TARGET_READLINE_LIBS" != ""; then
--  TARGET_READLINE_LIBS="$config_TARGET_READLINE_LIBS"
--else
--  CC=$TARGET_CC
--  LIBS=""
--  AC_SEARCH_LIBS(tgetent, [readline ncurses curses termcap])
--  AC_CHECK_LIB([readline], [readline])
--  TARGET_READLINE_LIBS="$LIBS"
--fi
-+TARGET_READLINE_LIBS="-lreadline"
- AC_SUBST(TARGET_READLINE_LIBS)
- ##########
-@@ -615,41 +614,8 @@
- ##########
- # Figure out where to get the READLINE header files.
- #
--AC_MSG_CHECKING([readline header files])
--found=no
--if test "$config_TARGET_READLINE_INC" != ""; then
--  TARGET_READLINE_INC=$config_TARGET_READLINE_INC
--  found=yes
--fi
--if test "$found" = "yes"; then
--  AC_MSG_RESULT($TARGET_READLINE_INC)
--else
--  AC_MSG_RESULT(not specified: still searching...)
--  AC_CHECK_HEADER(readline.h, [found=yes])
--fi
--if test "$found" = "no"; then
--  for dir in /usr /usr/local /usr/local/readline /usr/contrib /mingw; do
--    AC_CHECK_FILE($dir/include/readline.h, found=yes)
--    if test "$found" = "yes"; then
--      TARGET_READLINE_INC="-I$dir/include"
--      break
--    fi
--    AC_CHECK_FILE($dir/include/readline/readline.h, found=yes)
--    if test "$found" = "yes"; then
--      TARGET_READLINE_INC="-I$dir/include/readline"
--      break
--    fi
--  done
--fi
--if test "$found" = "yes"; then
--  if test "$TARGET_READLINE_LIBS" = ""; then
--    TARGET_HAVE_READLINE=0
--  else
--    TARGET_HAVE_READLINE=1
--  fi
--else
--  TARGET_HAVE_READLINE=0
--fi
-+TARGET_READLINE_INC=""
-+TARGET_HAVE_READLINE=1
- AC_SUBST(TARGET_READLINE_INC)
- AC_SUBST(TARGET_HAVE_READLINE)
diff --git a/meta/packages/sqlite/sqlite3/ldflags.patch b/meta/packages/sqlite/sqlite3/ldflags.patch
deleted file mode 100644 (file)
index ee5105f..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
---- sqlite-3.3.7/Makefile.in.orig      2006-08-20 23:05:36.000000000 +0200
-+++ sqlite-3.3.7/Makefile.in   2006-08-20 23:42:49.000000000 +0200
-@@ -31,6 +31,10 @@
- #
- TCC = @TARGET_CC@ @TARGET_CFLAGS@ -I. -I${TOP}/src
-+# OE overrides
-+#
-+TARGET_LFLAGS = @TARGET_LFLAGS@
-+
- # Define -DNDEBUG to compile without debugging (i.e., for production usage)
- # Omitting the define will cause extra debugging code to be inserted and
- # includes extra comments when "EXPLAIN stmt" is used.
-@@ -257,17 +261,17 @@
-           | $(NAWK) '{print $$5,$$6}' >last_change
- libsqlite3.la:        $(LIBOBJ)
--      $(LTLINK) -o libsqlite3.la $(LIBOBJ) $(LIBPTHREAD) \
-+      $(LTLINK) -o libsqlite3.la $(LIBOBJ) $(TARGET_LFLAGS) $(LIBPTHREAD) \
-               ${ALLOWRELEASE} -rpath $(libdir) -version-info "8:6:8"
- libtclsqlite3.la:     tclsqlite.lo libsqlite3.la
-       $(LTLINK) -o libtclsqlite3.la tclsqlite.lo \
--              $(LIBOBJ) @TCL_STUB_LIB_SPEC@ $(LIBPTHREAD) \
-+              $(LIBOBJ) @TCL_STUB_LIB_SPEC@ $(TARGET_LFLAGS) $(LIBPTHREAD) \
-                 -rpath $(libdir)/sqlite \
-               -version-info "8:6:8"
- sqlite3$(TEXE):       $(TOP)/src/shell.c libsqlite3.la sqlite3.h
--      $(LTLINK) $(READLINE_FLAGS) $(LIBPTHREAD) \
-+      $(LTLINK) $(TARGET_LFLAGS) $(READLINE_FLAGS) $(LIBPTHREAD) \
-               -o $@ $(TOP)/src/shell.c libsqlite3.la \
-               $(LIBREADLINE) $(TLIBS)
-@@ -456,12 +460,12 @@
- tclsqlite3:   tclsqlite-shell.lo libsqlite3.la
-       $(LTLINK) -o tclsqlite3 tclsqlite-shell.lo \
--               libsqlite3.la $(LIBTCL)
-+               libsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
- testfixture$(TEXE):   $(TOP)/src/tclsqlite.c libsqlite3.la $(TESTSRC)
-       $(LTLINK) -DTCLSH=1 -DSQLITE_TEST=1 -DSQLITE_CRASH_TEST=1 \
-               $(TEMP_STORE) -o testfixture $(TESTSRC) $(TOP)/src/tclsqlite.c \
--              libsqlite3.la $(LIBTCL)
-+              libsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
- fulltest:     testfixture$(TEXE) sqlite3$(TEXE)
-@@ -471,7 +475,7 @@
-       ./testfixture $(TOP)/test/quick.test
- sqlite3_analyzer$(TEXE):      $(TOP)/src/tclsqlite.c libtclsqlite3.la \
--                              $(TESTSRC) $(TOP)/tool/spaceanal.tcl
-+                              $(TARGET_LFLAGS) $(TESTSRC) $(TOP)/tool/spaceanal.tcl
-       sed \
-         -e '/^#/d' \
-         -e 's,\\,\\\\,g' \
-@@ -481,7 +485,7 @@
-         $(TOP)/tool/spaceanal.tcl >spaceanal_tcl.h
-       $(LTLINK) -DTCLSH=2 -DSQLITE_TEST=1 $(TEMP_STORE)\
-                 -o sqlite3_analyzer$(EXE) $(TESTSRC) $(TOP)/src/tclsqlite.c \
--              libtclsqlite3.la $(LIBTCL)
-+              libtclsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
- # Rules used to build documentation
- #
similarity index 67%
rename from meta/packages/sqlite/sqlite3_3.6.20.bb
rename to meta/packages/sqlite/sqlite3_3.6.23.1.bb
index 399b6e2a5a424fd823e48ef1563cc277e20fd8af..479516d261fef0cfca646b9d07bf44ab1dfbc052 100644 (file)
@@ -1,3 +1,3 @@
 require sqlite3.inc
 
-PR = "r2"
+PR = "r0"