]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/4.1: intel_idle: backport BXT CPU support
authorBruce Ashfield <bruce.ashfield@windriver.com>
Mon, 13 Jun 2016 15:56:33 +0000 (11:56 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 15 Jun 2016 16:36:36 +0000 (17:36 +0100)
Integrating upstream changes for intel_idle to support BXT CPU.

   Dasaratharaman Chandramouli (1):
     intel_idle: Support for Intel Xeon Phi Processor x200 Product Family

   Len Brown (4):
     intel_idle: Skylake Client Support
     intel_idle: Skylake Client Support - updated
     intel_idle: prevent SKL-H boot failure when C8+C9+C10 enabled
     intel_idle: add BXT support

Signed-off-by: Yu, Ong Hock <ong.hock.yu@intel.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
meta/recipes-kernel/linux/linux-yocto_4.1.bb

index 7cd18e0c7b66709a5f8394312bc533e93c208d86..ce19bd43459b866f00d0d0d136143f8f245cb6a9 100644 (file)
@@ -11,7 +11,7 @@ python () {
         raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
 }
 
-SRCREV_machine ?= "ec9e847b58017b62931bc4fbf7c968da5b0297cf"
+SRCREV_machine ?= "0ebcfeb720baaf05db903467d544c88238ef85f2"
 SRCREV_meta ?= "9f68667031354532563766a3d04ca8a618e9177a"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \
index 5b1b87f8284058da5387b21e8fd84b0640512ff3..54a932377b1dd590716421a425df8a3055d106b3 100644 (file)
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.1.26"
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
-SRCREV_machine ?= "f1069e0dbbc09f930ba8941e38859378ccc22f96"
+SRCREV_machine ?= "49719d35dca0562ab3e67f37de0d4430dad68a78"
 SRCREV_meta ?= "9f68667031354532563766a3d04ca8a618e9177a"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
index 4023c9b98ecee229c8fca71ee28b6290bfcdc764..c1d9f093449c61fe56386b82fec019396df39bf2 100644 (file)
@@ -11,14 +11,14 @@ KBRANCH_qemux86  ?= "standard/base"
 KBRANCH_qemux86-64 ?= "standard/base"
 KBRANCH_qemumips64 ?= "standard/mti-malta64"
 
-SRCREV_machine_qemuarm ?= "fa1f75003687404ebe8a07c967db1714c700f9ff"
-SRCREV_machine_qemuarm64 ?= "f1069e0dbbc09f930ba8941e38859378ccc22f96"
-SRCREV_machine_qemumips ?= "0e2b4693ec90691494752ff7854493f3c7f3fc2f"
-SRCREV_machine_qemuppc ?= "f1069e0dbbc09f930ba8941e38859378ccc22f96"
-SRCREV_machine_qemux86 ?= "f1069e0dbbc09f930ba8941e38859378ccc22f96"
-SRCREV_machine_qemux86-64 ?= "f1069e0dbbc09f930ba8941e38859378ccc22f96"
-SRCREV_machine_qemumips64 ?= "ca5c9e5ee5e3b569a55beb05e2f81078d3db2cef"
-SRCREV_machine ?= "f1069e0dbbc09f930ba8941e38859378ccc22f96"
+SRCREV_machine_qemuarm ?= "5e6960c60bf7c107978312f7e590bdec6676ceb2"
+SRCREV_machine_qemuarm64 ?= "49719d35dca0562ab3e67f37de0d4430dad68a78"
+SRCREV_machine_qemumips ?= "9c00d4cf09030ff438033ae094615894f3290628"
+SRCREV_machine_qemuppc ?= "49719d35dca0562ab3e67f37de0d4430dad68a78"
+SRCREV_machine_qemux86 ?= "49719d35dca0562ab3e67f37de0d4430dad68a78"
+SRCREV_machine_qemux86-64 ?= "49719d35dca0562ab3e67f37de0d4430dad68a78"
+SRCREV_machine_qemumips64 ?= "9aaa4d26a05a1816383a1e1dbc11de5830458eec"
+SRCREV_machine ?= "49719d35dca0562ab3e67f37de0d4430dad68a78"
 SRCREV_meta ?= "9f68667031354532563766a3d04ca8a618e9177a"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \