]> code.ossystems Code Review - openembedded-core.git/commitdiff
tcf-agent: add openssl into DEPENDS
authorDexuan Cui <dexuan.cui@intel.com>
Tue, 16 Aug 2011 06:37:14 +0000 (14:37 +0800)
committerSaul Wold <sgw@linux.intel.com>
Wed, 17 Aug 2011 05:54:05 +0000 (22:54 -0700)
[YOCTO #1330]

If tcf-agent's do_compile happens before openssl does populate_root, we'll
get such a compilation failure:
framework/channel_tcp.c:34:27: fatal error: openssl/ssl.h: No such file or directory

Thanks Kumar Gala for reporting this!

Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
Cc: Kumar Gala <galak@kernel.crashing.org>
meta/recipes-devtools/tcf-agent/tcf-agent_svn.bb

index 3f97f6952694dbc7cda60a282b3e9cfe4d903a90..37591c2b186e5986811089245f4fa676d0636a6c 100644 (file)
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://../epl-v10.html;md5=7aa4215a330a0a4f6a1cbf8da1a0879f
 
 SRCREV = "1855"
 PV = "0.0+svnr${SRCPV}"
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "svn://dev.eclipse.org/svnroot/dsdp/org.eclipse.tm.tcf/trunk;module=agent;proto=http \
            http://dev.eclipse.org/svnroot/dsdp/org.eclipse.tm.tcf/trunk/epl-v10.html;name=epl \
@@ -19,7 +19,7 @@ SRC_URI = "svn://dev.eclipse.org/svnroot/dsdp/org.eclipse.tm.tcf/trunk;module=ag
 SRC_URI[epl.md5sum] = "7aa4215a330a0a4f6a1cbf8da1a0879f"
 SRC_URI[epl.sha256sum] = "4fd64aeed340d62a64a8da4b371efe0f6d0d745f4d2dbefacba86c646d36bc72"
 
-DEPENDS = "util-linux"
+DEPENDS = "util-linux openssl"
 RDEPENDS_${PN} = "bash"
 
 S = "${WORKDIR}/agent"