]> code.ossystems Code Review - openembedded-core.git/commitdiff
cairo 1.10.2: enable tee backend
authorKoen Kooi <koen@dominion.thruhere.net>
Fri, 13 Jan 2012 09:01:27 +0000 (10:01 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 16 Jan 2012 12:23:20 +0000 (12:23 +0000)
This is needed for firefox:

| checking CAIRO_LIBS... -lcairo -lpixman-1 -lfreetype -lfontconfig
| checking for cairo-tee >= 1.10... Package cairo-tee was not found in the pkg-config search path. Perhaps you should add the directory containing `cairo-tee.pc' to the PKG_CONFIG_PATH environment variable No package 'cairo-tee' found
| configure: error: Library requirements (cairo-tee >= 1.10) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
meta/recipes-graphics/cairo/cairo.inc
meta/recipes-graphics/cairo/cairo_1.10.2.bb

index 930675d0ed069d62d2d76315bcce398caf9851cc..1d5d551cc781d102fee6d82431539e8a257c3a53 100644 (file)
@@ -19,7 +19,9 @@ PACKAGECONFIG[gtk-directfb] = "--enable-directfb=yes,,directfb"
 
 #check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points 
 require cairo-fpu.inc
-EXTRA_OECONF += "${@get_cairo_fpu_setting(bb, d)} "
+EXTRA_OECONF += "${@get_cairo_fpu_setting(bb, d)} \
+                 --enable-tee \
+                "
 
 
 inherit autotools pkgconfig
index 8202860ac9c638891735829c3ef7fc9817d2f593..826681f375091c92019ef6bb2039f040d04bb829 100644 (file)
@@ -2,7 +2,7 @@ require cairo.inc
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=e73e999e0c72b5ac9012424fa157ad77"
 
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "http://cairographics.org/releases/cairo-${PV}.tar.gz"