]> code.ossystems Code Review - openembedded-core.git/commitdiff
base-passwd: Fix race
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 29 Nov 2011 10:40:23 +0000 (10:40 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 29 Nov 2011 11:19:54 +0000 (11:19 +0000)
The do_package task this recipe injects depends on the output of
do_populate_sysroot to be present. This introduces the correct
dependency so that the package task works correctly.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/base-passwd/base-passwd_3.5.22.bb

index 5feb9242143845dd9d740af84b8fa53c0704863e..92ad0d9776048cdce19e050fafba22f897e7772d 100644 (file)
@@ -83,6 +83,8 @@ fi
        d.setVar('pkg_preinst_${PN}', preinst)
 }
 
+addtask do_package after do_populate_sysroot
+
 pkg_postinst_${PN}-update () {
 #!/bin/sh
 if [ -n "$D" ]; then