]> code.ossystems Code Review - openembedded-core.git/commitdiff
disable howl, enable hal at least for now
authorMatthew Allum <mallum@openedhand.com>
Thu, 3 Nov 2005 16:02:16 +0000 (16:02 +0000)
committerMatthew Allum <mallum@openedhand.com>
Thu, 3 Nov 2005 16:02:16 +0000 (16:02 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky@163 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/gnome/gnome-vfs-dbus_cvs.bb

index d94812fb54b3727a168a4d7653f9e8b7608d644e..6dc49a8b603c30eeb91c53aa3c796d1b0e346a34 100755 (executable)
@@ -1,7 +1,7 @@
 DEFAULT_PREFERENCE = "-1"
 
 SECTION = "x11/utils"
-DEPENDS = "gtk+ glib-2.0 gconf dbus libxml2 zlib bzip2"
+DEPENDS = "gtk+ glib-2.0 gconf dbus libxml2 zlib bzip2 hal gnome-mime-data"
 DESCRIPTION = "Virtual file system library using DBUS for communication."
 LICENSE = "GPLv2"
 MAINTAINER = "Chris Lord <chris@openedhand.com>"
@@ -11,6 +11,7 @@ RPROVIDES_${PN}-dev = "gnome-vfs-dev"
 RRECOMMENDS_${PN} = "gnome-vfs-plugin-file shared-mime-info"
 
 PV = "2.12.0cvs${CVSDATE}"
+PR = "r3"
 
 SRC_URI = "svn://anonymous@developer.imendio.com/svn/gnome-vfs-dbus;module=trunk;proto=http \
           file://no-gtk-doc.patch;patch=1 \
@@ -19,7 +20,7 @@ S = "${WORKDIR}/trunk"
 
 inherit pkgconfig autotools
 
-EXTRA_OECONF = "--with-ipc=dbus --disable-hal --disable-gtk-doc --disable-more-warnings"
+EXTRA_OECONF = "--with-ipc=dbus --enable-hal --disable-gtk-doc --disable-more-warnings --disable-howl"
 
 FILES_${PN} += " ${libdir}/vfs ${datadir}/dbus-1/services/dbus-vfs-daemon.service"
 FILES_${PN}-dev += " ${libdir}/gnome-vfs-2.0/modules/*.a ${libdir}/gnome-vfs-2.0/modules/*.la ${libdir}/gnome-vfs-2.0/include"