]> code.ossystems Code Review - openembedded-core.git/commitdiff
cross-linkage: Add dummy package to handle linking cross to staging
authorRichard Purdie <richard@openedhand.com>
Wed, 19 Sep 2007 12:59:01 +0000 (12:59 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 19 Sep 2007 12:59:01 +0000 (12:59 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2761 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/meta/cross-linkage_1.0.bb [new file with mode: 0644]

diff --git a/meta/packages/meta/cross-linkage_1.0.bb b/meta/packages/meta/cross-linkage_1.0.bb
new file mode 100644 (file)
index 0000000..2a9caca
--- /dev/null
@@ -0,0 +1,28 @@
+DESCRIPTION = "cross-linkage sets up symlinks between cross and staging so the compiler can find things"
+SECTION = "devel"
+PACKAGES = ""
+
+INHIBIT_DEFAULT_DEPS = "1"
+PR = "r0"
+
+SRC_URI = ""
+
+do_configure() {
+       :
+}
+
+do_compile () {
+       :
+}
+
+do_install() {
+       :
+}
+
+do_stage () {
+       install -d ${CROSS_DIR}/${TARGET_SYS}/
+       rm -rf ${CROSS_DIR}/${TARGET_SYS}/include
+       ln -s  ${STAGING_INCDIR}/ ${CROSS_DIR}/${TARGET_SYS}/include
+       rm -rf ${CROSS_DIR}/${TARGET_SYS}/lib
+       ln -s  ${STAGING_LIBDIR} ${CROSS_DIR}/${TARGET_SYS}/lib 
+}