]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-pygtk: Restore pkg-config file
authorGary Thomas <gary@mlbassoc.com>
Tue, 28 Oct 2014 15:05:47 +0000 (09:05 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 31 Dec 2014 10:17:11 +0000 (10:17 +0000)
Some previous version of this recipe was errantly removing the pygtk-2.0.pc
(pkg-config) file.  This is needed for other packages to be able to build
against this library.

Also update the .pc file to match current pkg-config use (libdir was missing).

(From OE-Core rev: 8c6158d7bcca2ecf3e150d1e8eaaaa4ece58e1e2)

Signed-off-by: Gary Thomas <gary@mlbassoc.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-devtools/python/python-pygtk/fix-pygtk-2.0.pc.patch [new file with mode: 0644]
meta/recipes-devtools/python/python-pygtk_2.24.0.bb

diff --git a/meta/recipes-devtools/python/python-pygtk/fix-pygtk-2.0.pc.patch b/meta/recipes-devtools/python/python-pygtk/fix-pygtk-2.0.pc.patch
new file mode 100644 (file)
index 0000000..b615654
--- /dev/null
@@ -0,0 +1,13 @@
+Upstream-Status: Inappropriate [configuration]
+
+Index: pygtk-2.24.0/pygtk-2.0.pc.in
+===================================================================
+--- pygtk-2.24.0.orig/pygtk-2.0.pc.in
++++ pygtk-2.24.0/pygtk-2.0.pc.in
+@@ -1,5 +1,6 @@
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
++libdir=@libdir@
+ includedir=@includedir@
+ datarootdir=@datarootdir@
+ datadir=@datadir@
index 8fc194f5e655f5c5c01427cdec9d50ab8eb3cc97..bd26ebb7da7a11584661948a85ae817e6c2c6923 100644 (file)
@@ -15,6 +15,7 @@ SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/2.24/${SRCNAME}-${PV}.tar
            file://fix-gtkunixprint.patch \
            file://prevent_to_get_display_during_import.patch \
            file://nodocs.patch \
+          file://fix-pygtk-2.0.pc.patch \
            file://acinclude.m4 \
            file://update-dependences-of-defs.c.patch"
 
@@ -43,7 +44,6 @@ do_configure_prepend() {
 do_install_append() {
        find ${D} -name "*.la"|xargs rm -f
        rm -f ${D}/${bindir}/pygtk-codegen-2.0
-       rm -rf ${D}/${libdir}/pkgconfig
        sed -i -e '1s|^#!.*python|#!/usr/bin/env python|' ${D}${bindir}/pygtk-demo
 }