]> code.ossystems Code Review - openembedded-core.git/commitdiff
gstreamer: Provide easy way to enable runtime debugging
authorGary Thomas <gary@mlbassoc.com>
Thu, 29 Mar 2012 14:40:04 +0000 (08:40 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 29 Mar 2012 21:19:15 +0000 (22:19 +0100)
The gstreamer framework has a very useful debugging setup which is
essential for debugging pipelines and plugins.  This patch makes
it simple to enable this (disabled by default).  To enable debugging,
just add this line to local.conf
  GSTREAMER_DEBUG = "--enable-debug"

Signed-off-by: Gary Thomas <gary@mlbassoc.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-multimedia/gstreamer/gst-ffmpeg_0.10.13.bb
meta/recipes-multimedia/gstreamer/gst-fluendo.inc
meta/recipes-multimedia/gstreamer/gst-plugins.inc
meta/recipes-multimedia/gstreamer/gstreamer_0.10.36.bb

index 5ee5066d87abc2a64a8eb28a9ec2ec3ae7301524..92cd349b7068fcfad16e3371a1229dcfb2298486 100644 (file)
@@ -25,7 +25,8 @@ SRC_URI[sha256sum] = "76fca05b08e00134e3cb92fa347507f42cbd48ddb08ed3343a912def18
 
 PR = "r1"
 
-EXTRA_OECONF = "--with-ffmpeg-extra-configure=\"--target-os=linux\" "
+GSTREAMER_DEBUG ?= "--disable-debug"
+EXTRA_OECONF = "--with-ffmpeg-extra-configure=\"--target-os=linux\" ${GSTREAMER_DEBUG}"
 
 # yasm not found, use --disable-yasm for a crippled build for libav
 EXTRA_OECONF_append_x86-64 = " --disable-yasm "
index 8b24cf757a6e2928c7715e67082afde641a29f0c..b2c7eea3cb41e02cbd9c60293b748226b1df5749 100644 (file)
@@ -11,4 +11,5 @@ FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
 FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
 FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"
 
-EXTRA_OECONF = "--disable-debug --disable-valgrind"
+GSTREAMER_DEBUG ?= "--disable-debug"
+EXTRA_OECONF = "${GSTREAMER_DEBUG} --disable-valgrind"
index f11a4af6689755765297f02b5e2c28ce8b1011ea..ccb81b328170231dc53e194b37856301b955cbf7 100644 (file)
@@ -10,7 +10,8 @@ FILESPATH =. "${FILE_DIRNAME}/gst-plugins:"
 
 SRC_URI = "http://gstreamer.freedesktop.org/src/${BPN}/${BPN}-${PV}.tar.bz2"
 
-EXTRA_OECONF = "--disable-valgrind --disable-debug --disable-examples "
+GSTREAMER_DEBUG ?= "--disable-debug"
+EXTRA_OECONF = "--disable-valgrind ${GSTREAMER_DEBUG} --disable-examples "
 
 acpaths = "-I ${S}/common/m4 -I ${S}/m4"
 
index 3c03c0db3f14c414c7820564fb690ab14432e402..278c20e033cb54c957c89d1497d55dcb4d1b543e 100644 (file)
@@ -20,7 +20,8 @@ SRC_URI[sha256sum] = "e556a529e0a8cf1cd0afd0cab2af5488c9524e7c3f409de29b5d82bb41
 
 inherit autotools pkgconfig gettext
 
-EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --with-check=no --disable-examples --disable-tests --disable-valgrind --disable-debug"
+GSTREAMER_DEBUG ?= "--disable-debug"
+EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --with-check=no --disable-examples --disable-tests --disable-valgrind ${GSTREAMER_DEBUG}"
 
 #do_compile_prepend () {
 #      mv ${WORKDIR}/gstregistrybinary.[ch] ${S}/gst/