]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm: save output of postinstall scripts when image first boot
authorKang Kai <kai.kang@windriver.com>
Mon, 25 Feb 2013 03:06:51 +0000 (11:06 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 7 Mar 2013 11:12:06 +0000 (11:12 +0000)
When image feature "debug-tweaks" is enabled, save output of post
install script to log file which can be configured when image first
boot.

[YOCTO #3223]

Signed-off-by: Kang Kai <kai.kang@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/rpm/rpm_5.4.9.bb

index 0b014b61c53b9a89a10ebd91bfd22fa3afa66ad8..cdfb5ff4bcad61f1eff7d1dd59151bff5e4d9211 100644 (file)
@@ -223,6 +223,7 @@ FILES_${PN} =  "${bindir}/rpm \
                ${libdir}/rpm/bin/wget \
                /var/lib/rpm \
                /var/cache/rpm \
+               ${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}run-postinsts \
                "
 
 FILES_${PN}-dbg += "${libdir}/rpm/.debug \
@@ -374,6 +375,9 @@ do_configure() {
 #
 POSTINSTALL_INITPOSITION ?= "98"
 
+POSTLOG ?= "/var/log/postinstall.log"
+REDIRECT_CMD = "${@base_contains('IMAGE_FEATURES', 'debug-tweaks', '>>${POSTLOG} 2>&1', '', d)}"
+
 do_install_append() {
        sed -i -e 's,%__check_files,#%%__check_files,' ${D}/${libdir}/rpm/macros
        sed -i -e 's,%__scriptlet_requires,#%%__scriptlet_requires,' ${D}/${libdir}/rpm/macros
@@ -459,7 +463,7 @@ do_install_append() {
 for i in \`ls /etc/rpm-postinsts/\`; do
        i=/etc/rpm-postinsts/$i
        echo "Running postinst $i..."
-       if [ -f $i ] && $i; then
+       if [ -f $i ] && $i ${REDIRECT_CMD}; then
                rm $i
        else
                echo "ERROR: postinst $i failed."