]> code.ossystems Code Review - openembedded-core.git/commitdiff
fix appearance of the calibration crosshair
authorTomas Frydrych <tf@openedhand.com>
Tue, 2 Jan 2007 16:15:45 +0000 (16:15 +0000)
committerTomas Frydrych <tf@openedhand.com>
Tue, 2 Jan 2007 16:15:45 +0000 (16:15 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1111 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/xtscal/xtscal/change-cross.patch [new file with mode: 0644]
meta/packages/xtscal/xtscal_0.6.3.bb

diff --git a/meta/packages/xtscal/xtscal/change-cross.patch b/meta/packages/xtscal/xtscal/change-cross.patch
new file mode 100644 (file)
index 0000000..3ecd36b
--- /dev/null
@@ -0,0 +1,16 @@
+--- tmp/main.c.orig    2007-01-02 15:39:54.000000000 +0000
++++ tmp/main.c 2007-01-02 15:39:54.000000000 +0000
+@@ -131,9 +131,10 @@
+ {
+   XRenderFillRectangles (dpy, PictOpSrc, pict, &rect_color, rectangles, 2);
+-  XFillArc (dpy, crosshair_w, crosshair_gc, (CROSSHAIR_SIZE / 2) - (WIDTH / 2) - 1, 
+-          (CROSSHAIR_SIZE / 2) - (WIDTH / 2) - 1,
+-          WIDTH + 1, WIDTH + 1, 0, 360 * 64);
++  XFillRectangle (dpy, crosshair_w, crosshair_gc,
++                (CROSSHAIR_SIZE / 2) - (WIDTH / 2),
++                (CROSSHAIR_SIZE / 2) - (WIDTH / 2),
++                WIDTH, WIDTH);
+ }
+ void
index 443b487065f662e6c34b6f479f5e96b1ffb8682b..3f2f43da9d58f32a783e102ec63dc75ede4c8ca3 100644 (file)
@@ -4,9 +4,10 @@ SECTION = "x11/base"
 
 DEPENDS = "virtual/libx11 libxft libxrandr xcalibrate"
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "${GPE_MIRROR}/xtscal-${PV}.tar.bz2 \
+           file://change-cross.patch;patch=1 \
            file://xtscal-cxk.patch;patch=1"
 
 inherit autotools