]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add ubootchart
authorRoss Burton <ross@openedhand.com>
Mon, 5 Nov 2007 10:15:24 +0000 (10:15 +0000)
committerRoss Burton <ross@openedhand.com>
Mon, 5 Nov 2007 10:15:24 +0000 (10:15 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3065 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta-extras/packages/ubootchart/files/sysvinit.patch [new file with mode: 0644]
meta-extras/packages/ubootchart/ubootchart_svn.bb [new file with mode: 0644]

diff --git a/meta-extras/packages/ubootchart/files/sysvinit.patch b/meta-extras/packages/ubootchart/files/sysvinit.patch
new file mode 100644 (file)
index 0000000..de9fb0b
--- /dev/null
@@ -0,0 +1,12 @@
+Index: ubootchart.conf
+===================================================================
+--- ubootchart.conf    (revision 9)
++++ ubootchart.conf    (working copy)
+@@ -1,6 +1,6 @@
+ # If you want to chain on and run somthing other than /sbin/init...
+-export init_prog=/sbin/init
++export init_prog=/sbin/init.sysvinit
+ # On startup ubootchart will mount a tmpfs filesystem at this
+ # location and chdir here. This is only used for the logging of
diff --git a/meta-extras/packages/ubootchart/ubootchart_svn.bb b/meta-extras/packages/ubootchart/ubootchart_svn.bb
new file mode 100644 (file)
index 0000000..b3f1ad3
--- /dev/null
@@ -0,0 +1,22 @@
+DESCRIPTION = "A boot profiling tool"
+HOMEPAGE = "http://code.google.com/p/ubootchart/"
+LICENSE="GPLv3"
+
+SRC_URI = "svn://ubootchart.googlecode.com/svn/;proto=http;module=trunk \
+        file://sysvinit.patch;patch=1;pnum=0"
+
+S = "${WORKDIR}/trunk"
+
+do_compile() {
+        ${CC} ${CFLAGS} ${LDFLAGS} ${LIBS} ${INCLUDES} ${S}/ubootchartd_bin.c -o ubootchartd_bin
+}
+
+do_install() {
+        install -m 0755 -d ${D}/sbin ${D}/etc/ubootchart
+        install -m 0755 ${S}/ubootchartd_bin ${D}/sbin
+        install -m 0755 ${S}/ubootchartd ${D}/sbin
+        install -m 0644 ${S}/ubootchart.conf ${D}/etc/ubootchart
+        install -m 0755 ${S}/start.sh ${D}/etc/ubootchart
+        install -m 0755 ${S}/finish.sh ${D}/etc/ubootchart
+}
+