]> code.ossystems Code Review - openembedded-core.git/commitdiff
liberation-fonts: use the new fontcache.bbclass
authorLaurentiu Palcu <laurentiu.palcu@intel.com>
Thu, 31 Jan 2013 08:35:37 +0000 (10:35 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 6 Feb 2013 09:35:03 +0000 (09:35 +0000)
This will add the proper postinst/postrm scriptlets.

[YOCTO #2599]

Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb

index b0a8242d824f1528de0f13202bff360d64e4f6e2..67e36e2a01ee1e79eee41211574644888cde1037 100644 (file)
@@ -9,10 +9,12 @@ SECTION = "x11/fonts"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
 RDEPENDS_${PN} = "fontconfig-utils"
-PR = "r2"
+PR = "r3"
 PE = "1"
 
-inherit allarch
+inherit allarch fontcache
+
+FONT_PACKAGES = "${PN}"
 
 SRC_URI = "https://fedorahosted.org/releases/l/i/liberation-fonts/liberation-fonts-${PV}.tar.gz \
            file://30-liberation-aliases.conf"
@@ -33,13 +35,5 @@ do_install () {
        install -m 0644 License.txt ${D}${datadir}/doc/${PN}/
 }
 
-pkg_postinst_${PN} () {
-#!/bin/sh
-if [ "x$D" != "x" ] ; then
-       exit 1
-fi
-fc-cache
-}
-
 PACKAGES = "${PN}"
 FILES_${PN} += "${sysconfdir} ${datadir}"