]> code.ossystems Code Review - openembedded-core.git/commitdiff
ffmpeg: disable asm for x32
authorChristopher Larson <chris_larson@mentor.com>
Wed, 14 Dec 2016 03:04:34 +0000 (20:04 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 9 Jan 2017 13:34:31 +0000 (13:34 +0000)
This is the usual way this is handled in desktop distros (see debian, gentoo).
I wasn't able to track down a patch to add proper x32 support to ffmpeg. There
was, however, a libav patch series which may be worth investigating.

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-multimedia/ffmpeg/ffmpeg_3.2.2.bb

index 4fac46b117079a78b7cb9ad1f9ff06aa6fc7e3d1..66718c4b3714f1d5cb47a0dd993057c43d53a717 100644 (file)
@@ -92,6 +92,8 @@ EXTRA_OECONF = " \
     ${@bb.utils.contains('AVAILTUNES', 'mips32r2', '', '--disable-mipsdsp --disable-mipsdspr2', d)} \
 "
 
+EXTRA_OECONF_append_linux-gnux32 = " --disable-asm"
+
 do_configure() {
     ${S}/configure ${EXTRA_OECONF}
 }