]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto: export kernel configuration audit to the console
authorBruce Ashfield <bruce.ashfield@windriver.com>
Mon, 31 Jan 2011 20:52:48 +0000 (15:52 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 1 Feb 2011 23:59:43 +0000 (23:59 +0000)
Fixes [BUGID #692]

Previously the information dumped by the kernel configuration audit
scripts was only placed in log files. This isn't as useful as it
could be, since they are rarely checked. This change takes the
output from kconf_check and explicitly displays it to the user.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
meta/classes/kernel-yocto.bbclass
meta/conf/distro/include/poky-default-revisions.inc
meta/recipes-kernel/linux/linux-yocto.inc
meta/recipes-kernel/linux/linux-yocto_git.bb

index 8479b395cdf9bcb992a3b5a8b0ae1468b91e23b4..70521a4fb36abcaa4b4434831c57d565092d9c09 100644 (file)
@@ -131,17 +131,22 @@ do_kernel_configme() {
                echo "ERROR. Could not configure ${KMACHINE}-${LINUX_KERNEL_TYPE}"
                exit 1
        fi
-
+       
        echo "# Global settings from linux recipe" >> ${B}/.config
        echo "CONFIG_LOCALVERSION="\"${LINUX_VERSION_EXTENSION}\" >> ${B}/.config
 }
 
-do_kernel_configcheck() {
-       echo "[INFO] validating kernel configuration"
-       cd ${B}/..
-       kconf_check ${B}/.config ${B} ${S} ${B} ${LINUX_VERSION} ${KMACHINE}-${LINUX_KERNEL_TYPE}
-}
+python do_kernel_configcheck() {
+    import bb, re, string, sys, commands
 
+    bb.plain("NOTE: validating kernel configuration")
+
+    pathprefix = "export PATH=%s; " % bb.data.getVar('PATH', d, True)
+    cmd = bb.data.expand("cd ${B}/..; kconf_check -${LINUX_KERNEL_TYPE}-config-${LINUX_VERSION} ${B} ${S} ${B} ${KBRANCH}",d )
+    ret, result = commands.getstatusoutput("%s%s" % (pathprefix, cmd))
+
+    bb.plain( "%s" % result )
+}
 
 # Ensure that the branches (BSP and meta) are on the locatios specified by
 # their SRCREV values. If they are NOT on the right commits, the branches
index cd6c95fd8e2ae9b700f163362255487d0abd3a09..a6d5903505b9f5845678cf56e211b63c2e55dfef 100644 (file)
@@ -59,7 +59,7 @@ SRCREV_pn-gypsy ??= "147"
 SRCREV_pn-inputproto ??= "7203036522ba9d4b224d282d6afc2d0b947711ee"
 SRCREV_pn-inputproto-native ??= "7203036522ba9d4b224d282d6afc2d0b947711ee"
 SRCREV_pn-inputproto-nativesdk ??= "7203036522ba9d4b224d282d6afc2d0b947711ee"
-SRCREV_pn-kern-tools-native ??= "8832b75dc2e494ae96ca3e1dee7bfde2f3096904"
+SRCREV_pn-kern-tools-native ??= "fde7ef8fa8043607752563b9b7908f487eb2f7dd"
 SRCREV_pn-libdrm ??= "3f3c5be6f908272199ccf53f108b1124bfe0a00e"
 SRCREV_pn-libfakekey ??= "e8c2e412ea4a417afc1f30e32cb7bdc508b1dccc"
 SRCREV_pn-libgdbus ??= "aeab6e3c0185b271ca343b439470491b99cc587f"
@@ -107,7 +107,7 @@ SRCREV_machine_pn-linux-yocto_atom-pc ?= "a9d833fda90e2f1257888a97e092135610b5f2
 SRCREV_machine_pn-linux-yocto_routerstationpro ?= "219a5f9dc6e5beced36184e141f80b2df61ae32f"
 SRCREV_machine_pn-linux-yocto_mpc8315e-rdb ?= "3f01b98238c2ff7913ce9f68f9db5ae9538717bc"
 SRCREV_machine_pn-linux-yocto_beagleboard ?= "a9d833fda90e2f1257888a97e092135610b5f259"
-SRCREV_meta_pn-linux-yocto ?= "8a49ef6f1a43dabbce34a9ee9a1be08b26fc511c"
+SRCREV_meta_pn-linux-yocto ?= "e8b8c1ae44932835f4f79e77180d3ce5e4b1ec99"
 SRCREV_pn-linux-libc-headers-yocto ??= "a9d833fda90e2f1257888a97e092135610b5f259"
 SRCREV_pn-matchbox-config-gtk ??= "3ed74dfb7c57be088a5ab36e446c0ccde9fa1028"
 SRCREV_pn-matchbox-desktop-sato ??= "76"
index dc4ab5503cfefb6ec7bfb5f7305f74283df6894d..3ad849e46e0c627d727e3e510e9d65fb3ee5238f 100644 (file)
@@ -15,7 +15,6 @@ LINUX_KERNEL_TYPE ?= standard
 do_patch[depends] = "kern-tools-native:do_populate_sysroot"
 
 addtask kernel_configme before do_configure after do_patch
-addtask kernel_configcheck after do_configure before do_compile
 
 # Pick up shared functions
 inherit kernel-yocto
index 7833f65fa4ecc9b4f9947497f456d184364168ec..b1486bce18cf9d083975fed00bcfc8f7ee6c00a0 100644 (file)
@@ -30,5 +30,6 @@ KERNEL_FEATURES=features/netfilter
 # extra tasks
 addtask kernel_link_vmlinux after do_compile before do_install
 addtask validate_branches before do_patch after do_kernel_checkout
+addtask kernel_configcheck after do_configure before do_compile
 
 require linux-tools.inc