]> code.ossystems Code Review - openembedded-core.git/commitdiff
lttng: recognize aarch64
authorJoe Slater <jslater@windriver.com>
Thu, 18 Dec 2014 08:51:06 +0000 (16:51 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 22 Dec 2014 10:53:55 +0000 (10:53 +0000)
Add aarch64 architecture to liburcu and lttng-ust.
Internally it is treated the same as "arm".

Signed-off-by: Joe Slater <jslater@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/lttng/lttng-ust/add-aarch64.patch [new file with mode: 0644]
meta/recipes-kernel/lttng/lttng-ust_2.5.0.bb
meta/recipes-support/liburcu/files/aarch64.patch [new file with mode: 0644]
meta/recipes-support/liburcu/liburcu_0.8.5.bb

diff --git a/meta/recipes-kernel/lttng/lttng-ust/add-aarch64.patch b/meta/recipes-kernel/lttng/lttng-ust/add-aarch64.patch
new file mode 100644 (file)
index 0000000..cec5410
--- /dev/null
@@ -0,0 +1,19 @@
+lttng-ust: add aarch64 recognition
+
+Treat the same as "arm".
+
+Upstream-Status: Pending
+
+Signed-off-by: joe.slater@windriver.com
+
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -230,6 +230,7 @@ changequote([,])dnl
+       s390) NO_UNALIGNED_ACCESS=1 ;;
+       s390x) NO_UNALIGNED_ACCESS=1 ;;
+         arm*) NO_UNALIGNED_ACCESS=1 ;;
++        aarch64) NO_UNALIGNED_ACCESS=1 ;;
+       mips*) NO_UNALIGNED_ACCESS=1 ;;
+       tile*) NO_UNALIGNED_ACCESS=1 ;;
+       *) AC_MSG_ERROR([unable to detect alignment requirements (unsupported architecture ($host_cpu)?)]) ;;
index 71ea5bccf26ea945cd6a2208640fe55745666e75..e07d3c726ba420916fc652cf4fc6f259a088fbcb 100644 (file)
@@ -24,6 +24,7 @@ PE = "2"
 
 SRC_URI = "git://git.lttng.org/lttng-ust.git;branch=stable-2.5 \
            file://lttng-ust-doc-examples-disable.patch \
+           file://add-aarch64.patch \
           "
 
 S = "${WORKDIR}/git"
diff --git a/meta/recipes-support/liburcu/files/aarch64.patch b/meta/recipes-support/liburcu/files/aarch64.patch
new file mode 100644 (file)
index 0000000..c6cc8c2
--- /dev/null
@@ -0,0 +1,19 @@
+libucru: recognize aarch64
+
+Make the same as "arm" internally.
+
+Upstream-Status: Pending
+
+Signed-off-by: joe.slater@windriver.com
+
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -77,6 +77,7 @@ AS_CASE([$host_cpu],
+       [alpha*], [ARCHTYPE="alpha"],
+       [ia64], [ARCHTYPE="gcc"],
+       [arm*], [ARCHTYPE="arm"],
++      [aarch64], [ARCHTYPE="arm"],
+       [mips*], [ARCHTYPE="mips"],
+       [tile*], [ARCHTYPE="gcc"],
+       [ARCHTYPE="unknown"]
index 04c990e837dd0140bdd71f31d434963cefd66f37..62323d3fd77c7faf75542c562335710bfe131998 100644 (file)
@@ -9,6 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=0f060c30a27922ce9c0d557a639b4fa3 \
 
 SRC_URI = "http://lttng.org/files/urcu/userspace-rcu-${PV}.tar.bz2 \
            file://Revert-Blacklist-ARM-gcc-4.8.0-4.8.1-4.8.2.patch \
+           file://aarch64.patch \
           "
 
 SRC_URI[md5sum] = "24ba9e03542b747d3378434eb0041acf"