]> code.ossystems Code Review - openembedded-core.git/commitdiff
watchdog: Disable nfs on musl targets
authorKhem Raj <raj.khem@gmail.com>
Thu, 17 Mar 2016 05:18:19 +0000 (05:18 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 20 Mar 2016 22:57:55 +0000 (22:57 +0000)
Fixes build issue on musl where it needs to link to sunrpc
when enabling nfs

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-extended/watchdog/watchdog_5.14.bb

index fc717bc53d3baef59005dd27c13e052067c68468..7330238972a7cd7400a91c48f8cdbe0959ab863f 100644 (file)
@@ -28,6 +28,7 @@ inherit update-rc.d
 DEPENDS_append_libc-musl = " libtirpc "
 CFLAGS_append_libc-musl = " -I${STAGING_INCDIR}/tirpc "
 LDFLAGS_append_libc-musl = " -ltirpc "
+EXTRA_OECONF_append_libc-musl = " --disable-nfs "
 
 INITSCRIPT_NAME = "watchdog.sh"
 INITSCRIPT_PARAMS = "start 15 1 2 3 4 5 . stop 85 0 6 ."