]> code.ossystems Code Review - openembedded-core.git/commitdiff
nss: pay attention to CFLAGS
authorJoe Slater <jslater@windriver.com>
Wed, 15 Nov 2017 18:54:09 +0000 (10:54 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 29 Nov 2017 23:41:36 +0000 (23:41 +0000)
nss ignores CFLAGS so we suggest them via CC.

Signed-off-by: Joe Slater <jslater@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-support/nss/nss_3.33.bb

index e3d4f96946e3ef7f3c570c37fb40f64f42bbecca..06d81ce05d375e4e6417b33ef535eb5dd5ef6c83 100644 (file)
@@ -104,7 +104,12 @@ do_compile() {
     # We can modify CC in the environment, but if we set it via an
     # argument to make, nsinstall, a host program, will also build with it!
     #
-    export CC="${CC} -g"
+    # nss pretty much does its own thing with CFLAGS, so we put them into CC.
+    # Optimization will get clobbered, but most of the stuff will survive.
+    # The motivation for this is to point to the correct place for debug
+    # source files and CFLAGS does that.  Nothing uses CCC.
+    #
+    export CC="${CC} ${CFLAGS}"
     make -C ./nss CCC="${CXX} -g" \
         OS_TEST=${OS_TEST} \
         RPATH="${RPATH}"