]> code.ossystems Code Review - openembedded-core.git/commitdiff
staging-linkage: Add from OE
authorRichard Purdie <richard@openedhand.com>
Tue, 11 Mar 2008 00:08:58 +0000 (00:08 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 11 Mar 2008 00:08:58 +0000 (00:08 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3987 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/meta/staging-linkage_1.0.bb [new file with mode: 0644]

diff --git a/meta/packages/meta/staging-linkage_1.0.bb b/meta/packages/meta/staging-linkage_1.0.bb
new file mode 100644 (file)
index 0000000..95d82d3
--- /dev/null
@@ -0,0 +1,29 @@
+DESCRIPTION = "staging-linkage sets up symlinks in staging so old compilers continue to work with the sysroot staging layout changes"
+SECTION = "devel"
+PACKAGES = ""
+
+INHIBIT_DEFAULT_DEPS = "1"
+EXCLUDE_FROM_WORLD = "1"
+PR = "r0"
+
+SRC_URI = ""
+
+do_configure() {
+       :
+}
+
+do_compile () {
+       :
+}
+
+do_install() {
+       :
+}
+
+do_stage () {
+       if [ -e ${STAGING_DIR_HOST}${layout_base_libdir} ]; then
+               cp -pPRr ${STAGING_DIR_HOST}${layout_base_libdir}/* ${STAGING_LIBDIR}
+               mv ${STAGING_DIR_HOST}${layout_base_libdir}/ ${STAGING_DIR_HOST}${layout_libdir}-oldbackup
+       fi
+       ln -s ${STAGING_LIBDIR}/ ${STAGING_DIR_HOST}${layout_base_libdir}
+}