]> code.ossystems Code Review - openembedded-core.git/commitdiff
ADT: bug fix for nameing and do_patch sequence
authorLiping Ke <liping.ke@intel.com>
Thu, 17 Mar 2011 05:28:42 +0000 (13:28 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 17 Mar 2011 11:50:21 +0000 (11:50 +0000)
This patch is for fixing the x86-64 image name bug and also,
do_patch must be done before do_deploy.

Signed-off-by: Liping Ke <liping.ke@intel.com>
meta/recipes-devtools/installer/adt-installer/adt_installer
meta/recipes-devtools/installer/adt-installer/scripts/adt_installer_internal
meta/recipes-devtools/installer/adt-installer_1.0.bb

index b1b497002eabfaa60fe29054ef1bb17431c92d56..d7a40c24796ea4830c5d65d8a84f1bde50db1f96 100755 (executable)
@@ -236,12 +236,15 @@ wget "$YOCTOADT_IPKG_REPO/$1" -P $LOCAL_DOWNLOAD --progress=bar:force 2>&1 | tee
 #Need two input params, $1 -- arch_type(arm powerpc x86 mips) $2 rootfs_image_type (a list of sdk sato minimal lsb)
 get_qemu_image()
 {
-  if [ "$1" == "x86" ]; then
-    qemu_kernel="bzImage-qemu$1.bin"
+  local target=`echo "$1" | sed -e 's/x86_64/x86-64/'`
+
+  if [ "$1" == "x86" ] || [ "$1" == "x86_64" ]; then
+    qemu_kernel="bzImage-qemu$target.bin"
   elif [ "$1" == "mips" ]; then
-    qemu_kernel="vmlinux-qemu$1.bin"
+    qemu_kernel="vmlinux-qemu$target.bin"
   else
-    qemu_kernel="zImage-qemu$1.bin"
+    qemu_kernel="zImage-qemu$target.bin"
   fi
 
   #echo_info "[ADT_INST] Downloading qemu kernel binary: $qemu_kernel"
@@ -250,7 +253,7 @@ get_qemu_image()
   
   for image_type in $select_rootfs; do
     #echo_info "[ADT_INST] Downloading rootfs file: poky-image-$image_type-qemu$1.tar.bz2"
-    filename="poky-image-$image_type-qemu$1.tar.bz2"
+    filename="poky-image-$image_type-qemu$target.tar.bz2"
     download_file qemu$1/$filename
     check_result
   done
index e1d4e63b18f66c75b03456b43bda4f31b1c2bd60..65b1b54c72a685e3c1277ef5375ba0fe5a4e3962 100755 (executable)
@@ -170,7 +170,9 @@ fi
 
 echo_info "Installing target sysroot for arch: $1, rootfs type: $target_sysroot_image, location: $target_sysroot"
 
-sysroot_image_name="poky-image-$target_sysroot_image-qemu$1.tar.bz2"
+
+qemu_type=`echo "$1" | sed -e 's/x86_64/x86-64/'`
+sysroot_image_name="poky-image-$target_sysroot_image-qemu$qemu_type.tar.bz2"
     #echo_info "Extracting rootfs: $sysroot_image_name, using pseudo..."
 
 scripts/extract_rootfs $sysroot_image_name $target_sysroot $POKY_NATIVE_SYSROOT $user_inst_type
@@ -179,8 +181,6 @@ check_result
 echo_info "Updating environment script with target sysroot location."
 if [ "$1" == "x86"  ]; then
   env_filename=`ls $INSTALL_FOLDER/environment-setup-i586*`
-elif [ "$1" == "ppc"  ]; then
-  env_filename=`ls $INSTALL_FOLDER/environment-setup-powerpc*`
 else
   env_filename=`ls $INSTALL_FOLDER/environment-setup-$1*`
 fi
index ff7afe6623ff3d25a99b1126fafdb0678aa269ad..7e82c926770bb67058635061cdbfd71b6e6b5be7 100644 (file)
@@ -82,4 +82,4 @@ do_package_write_rpm[noexec] = "1"
 do_package_write_deb[noexec] = "1"
 do_poplulate_sysroot[noexec] = "1"
 
-addtask deploy before do_populate_sysroot after do_unpack
+addtask deploy before do_populate_sysroot after do_patch