]> code.ossystems Code Review - openembedded-core.git/commitdiff
util-linux-native: Avoid use of getrandom
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 14 Aug 2017 14:20:39 +0000 (15:20 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 15 Aug 2017 23:01:45 +0000 (00:01 +0100)
getrandom() is only available in glibc 2.25+ and uninative may relocate binaries
onto systems that don't have this function. For now, force the code to the older
codepath until we can come up with a better solution for this kind of issue.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/util-linux/util-linux/no_getrandom.patch [new file with mode: 0644]
meta/recipes-core/util-linux/util-linux_2.30.bb

diff --git a/meta/recipes-core/util-linux/util-linux/no_getrandom.patch b/meta/recipes-core/util-linux/util-linux/no_getrandom.patch
new file mode 100644 (file)
index 0000000..b9fa1ca
--- /dev/null
@@ -0,0 +1,21 @@
+getrandom() is only available in glibc 2.25+ and uninative may relocate 
+binaries onto systems that don't have this function. For now, force the 
+code to the older codepath until we can come up with a better solution 
+for this kind of issue.
+
+Upstream-Status: Inappropriate
+RP
+2016/8/15
+
+Index: util-linux-2.30/configure.ac
+===================================================================
+--- util-linux-2.30.orig/configure.ac
++++ util-linux-2.30/configure.ac
+@@ -399,7 +399,6 @@ AC_CHECK_FUNCS([ \
+       getdtablesize \
+       getexecname \
+       getmntinfo \
+-      getrandom \
+       getrlimit \
+       getsgnam \
+       inotify_init \
index 6b309b555fdad20fe039f65d7a3a03e310819f54..39449d9ac9ead6eb1d8ced31f7d1cbb568fc733a 100644 (file)
@@ -15,6 +15,7 @@ SRC_URI += "file://configure-sbindir.patch \
             file://display_testname_for_subtest.patch \
             file://avoid_parallel_tests.patch \
 "
+SRC_URI_append_class-native = " file://no_getrandom.patch"
 SRC_URI[md5sum] = "eaa3429150268027908a1b8ae6ee9a62"
 SRC_URI[sha256sum] = "c208a4ff6906cb7f57940aa5bc3a6eed146e50a7cc0a092f52ef2ab65057a08d"