]> code.ossystems Code Review - openembedded-core.git/commitdiff
udev-extraconf: introduce multiple blacklist files for more complex setups
authorJens Rehsack <rehsack@gmail.com>
Tue, 5 Jan 2016 16:11:42 +0000 (17:11 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 5 Jan 2016 17:55:05 +0000 (17:55 +0000)
In cases where a target image wants prevent the recovery partition is mounted
automatically, but the recovery partition identifier moves with the device
(internal flash, sd card, usb stick, ...), device/machine dependend extra
blacklists might be desired.

The grep utility prints the file name for each match when there is more
than one file to search. Add -h to suppress the prefixing of file names
on output.

Signed-off-by: Jens Rehsack <sno@netbsd.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/udev/udev-extraconf/mount.sh
meta/recipes-core/udev/udev-extraconf_1.1.bb

index 3eea910854f350176f9f661b0a7eb226e372e560..d760328a09ff9a7afa29d92c40cf54f3bf98101a 100644 (file)
@@ -8,7 +8,7 @@
 MOUNT="/bin/mount"
 PMOUNT="/usr/bin/pmount"
 UMOUNT="/bin/umount"
-for line in `grep -v ^# /etc/udev/mount.blacklist`
+for line in `grep -h -v ^# /etc/udev/mount.blacklist /etc/udev/mount.blacklist.d/*`
 do
        if [ ` expr match "$DEVNAME" "$line" ` -gt 0 ];
        then
index 6fbd92548ae76b37b54e412e6a563a64c8e9f31f..ecd4a8aab56ae7e3987546a68a0d47c610fe6872 100644 (file)
@@ -23,6 +23,7 @@ do_install() {
     install -m 0644 ${WORKDIR}/autonet.rules       ${D}${sysconfdir}/udev/rules.d/autonet.rules
     install -m 0644 ${WORKDIR}/localextra.rules    ${D}${sysconfdir}/udev/rules.d/localextra.rules
 
+    install -d ${D}${sysconfdir}/udev/mount.blacklist.d
     install -m 0644 ${WORKDIR}/mount.blacklist     ${D}${sysconfdir}/udev/
 
     install -d ${D}${sysconfdir}/udev/scripts/