]> code.ossystems Code Review - openembedded-core.git/commitdiff
Fix flac build on e500mc cores
authorMatthew McClintock <msm@freescale.com>
Thu, 29 Sep 2011 04:21:06 +0000 (23:21 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 29 Sep 2011 18:31:38 +0000 (19:31 +0100)
This core does not have altivec, so we disable it in the build,
also reestablish the config option to enable/disable building
with altivec

If SPE is not detected we always build with altivec which is wrong. This
will check to make sure altivec is enabled and pass build options
through accordingly

Signed-off-by: Matthew McClintock <msm@freescale.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-multimedia/flac/flac-1.2.1/0001-No-AltiVec-on-SPE.patch
meta/recipes-multimedia/flac/flac_1.2.1.bb

index 658e1903d2844b7ff893a3bc9aee9b30c08ce6ed..5ca8b35142f3390ece9f58a979cbc2f7d6dad4d4 100644 (file)
@@ -39,14 +39,16 @@ diff --git a/src/libFLAC/Makefile.am b/src/libFLAC/Makefile.am
 index cbfb0ac..5785372 100644
 --- a/src/libFLAC/Makefile.am
 +++ b/src/libFLAC/Makefile.am
-@@ -40,8 +40,13 @@ if FLaC__SYS_DARWIN
+@@ -40,8 +40,15 @@ if FLaC__SYS_DARWIN
  CPUCFLAGS = -faltivec -force_cpusubtype_ALL -DFLAC__NO_ASM
  else
  # Linux-gcc for PPC does not have -force_cpusubtype_ALL, it is Darwin-specific
 +CPUCFLAGS =
 +if FLaC__CPU_PPC_SPE
 +else
++if FLaC__USE_ALTIVEC
 +CPUCFLAGS += -maltivec -mabi=altivec
++endif
 +endif
  #@@@ PPC optimizations temporarily disabled
 -CPUCFLAGS = -maltivec -mabi=altivec -DFLAC__NO_ASM
index 341047abb6b137bd22dab861867ec4fb247c7295..652d69a13d86b8f0be7e8486f404f1aa8394e951 100644 (file)
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = "file://COPYING.FDL;md5=ad1419ecc56e060eccf8184a87c4285f \
                     file://include/FLAC/all.h;beginline=64;endline=69;md5=64474f2b22e9e77b28d8b8b25c983a48"
 DEPENDS = "libogg"
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/flac/flac-${PV}.tar.gz \
            file://disable-xmms-plugin.patch \
@@ -36,6 +36,9 @@ EXTRA_OECONF = "--disable-oggtest --disable-id3libtest \
                 --without-xmms-exec-prefix \
                 --without-libiconv-prefix \
                 --without-id3lib"
+EXTRA_OECONF_prepend_e500mc = "--disable-altivec "
+EXTRA_OECONF_prepend_e5500 = "--disable-altivec "
+EXTRA_OECONF_prepend_e5500-64b = "--disable-altivec "
 
 PACKAGES += "libflac libflac++ liboggflac liboggflac++"
 FILES_${PN} = "${bindir}/*"