]> code.ossystems Code Review - openembedded-core.git/commitdiff
glibc: fix CVE-2019-9169
authorRoss Burton <ross.burton@intel.com>
Thu, 21 Mar 2019 12:31:12 +0000 (12:31 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 24 Mar 2019 17:00:42 +0000 (17:00 +0000)
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/glibc/glibc/CVE-2019-9169.patch [new file with mode: 0644]
meta/recipes-core/glibc/glibc_2.29.bb

diff --git a/meta/recipes-core/glibc/glibc/CVE-2019-9169.patch b/meta/recipes-core/glibc/glibc/CVE-2019-9169.patch
new file mode 100644 (file)
index 0000000..bc40361
--- /dev/null
@@ -0,0 +1,36 @@
+CVE: CVE-2019-9169
+Upstream-Status: Backport
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+From 583dd860d5b833037175247230a328f0050dbfe9 Mon Sep 17 00:00:00 2001
+From: Paul Eggert <eggert@cs.ucla.edu>
+Date: Mon, 21 Jan 2019 11:08:13 -0800
+Subject: [PATCH] regex: fix read overrun [BZ #24114]
+
+Problem found by AddressSanitizer, reported by Hongxu Chen in:
+https://debbugs.gnu.org/34140
+* posix/regexec.c (proceed_next_node):
+Do not read past end of input buffer.
+---
+ posix/regexec.c |  6 ++++--
+ 2 files changed, 13 insertions(+), 3 deletions(-)
+
+diff --git a/posix/regexec.c b/posix/regexec.c
+index 91d5a79..084b122 100644
+--- a/posix/regexec.c
++++ b/posix/regexec.c
+@@ -1293,8 +1293,10 @@ proceed_next_node (const re_match_context_t *mctx, Idx nregs, regmatch_t *regs,
+             else if (naccepted)
+               {
+                 char *buf = (char *) re_string_get_buffer (&mctx->input);
+-                if (memcmp (buf + regs[subexp_idx].rm_so, buf + *pidx,
+-                            naccepted) != 0)
++                if (mctx->input.valid_len - *pidx < naccepted
++                    || (memcmp (buf + regs[subexp_idx].rm_so, buf + *pidx,
++                                naccepted)
++                        != 0))
+                   return -1;
+               }
+           }
+-- 
+2.9.3
index db856c70adb873049985cee7cf48b77f9acc8e61..9184c5932cc803b94f4146066a3b0b6ce0453af2 100644 (file)
@@ -55,6 +55,7 @@ SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
            file://0029-inject-file-assembly-directives.patch \
            file://0030-locale-prevent-maybe-uninitialized-errors-with-Os-BZ.patch \
            file://0001-x86-64-memcmp-Use-unsigned-Jcc-instructions-on-size-.patch \
+           file://CVE-2019-9169.patch \
 "
 
 S = "${WORKDIR}/git"