]> code.ossystems Code Review - openembedded-core.git/commitdiff
musicbrainz: handle rebuilds
authorRoss Burton <ross.burton@intel.com>
Wed, 9 Jan 2013 16:26:04 +0000 (16:26 +0000)
committerSaul Wold <sgw@linux.intel.com>
Thu, 10 Jan 2013 00:40:38 +0000 (16:40 -0800)
When rebuilding build-native already exists.  Sadly handling the directory
existing causes cmake to forkbomb when rebuilding, so delete an existing
build-native.

Also remove a variable that cmake warns isn't being used, and just build the
tool that we need natively, not the entire library.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-multimedia/musicbrainz/libmusicbrainz_git.bb

index 7343662d0157bc6e075d83a6f683207531a4c898..21eec6df5abef06777dd0e0dedb302741dfc98f9 100644 (file)
@@ -20,15 +20,17 @@ LDFLAGS_prepend_libc-uclibc = " -lpthread "
 inherit cmake pkgconfig
 
 do_configure_prepend() {
+    # The native build really doesn't like being rebuilt, so delete
+    # it if it's already present.
+    rm -rf build-native
     mkdir build-native
     cd build-native
     cmake -DCMAKE_C_FLAGS=${BUILD_CFLAGS} \
             -DCMAKE_C_COMPILER=${BUILD_CC} \
             -DCMAKE_CXX_FLAGS=${BUILD_CXXFLAGS} \
             -DCMAKE_CXX_COMPILER=${BUILD_CXX} \
-            -DCMAKE_LINK_FLAGS=${BUILD_LDFLAGS} \
             ..
-    make
+    make make-c-interface
     cd ..
 }