]> code.ossystems Code Review - openembedded-core.git/commitdiff
initramfs-framework: udev: Handle alternative binary paths
authorOtavio Salvador <otavio@ossystems.com.br>
Tue, 27 Nov 2012 11:55:02 +0000 (11:55 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 3 Dec 2012 14:21:31 +0000 (14:21 +0000)
This allows use of udev daemon for different installation destinations
so allowing use of udev's from systemd code for initramfs.

Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/initrdscripts/initramfs-framework/udev
meta/recipes-core/initrdscripts/initramfs-framework_1.0.bb

index 15a1d5ba0696da4e30d3cb783fc8a42c26cc4198..7fbcc61d9cf4138a05b3c3e054c752776a39a4b7 100644 (file)
@@ -1,10 +1,25 @@
 #!/bin/sh
-# Copyright (C) 2011 O.S. Systems Software LTDA.
+# Copyright (C) 2011, 2012 O.S. Systems Software LTDA.
 # Licensed on MIT
 
+udev_daemon() {
+       OPTIONS="/sbin/udevd /lib/udev/udevd /lib/systemd/systemd-udevd"
+
+       for o in $OPTIONS; do
+               if [ -x "$o" ]; then
+                       echo $o
+                       return 0
+               fi
+       done
+
+       return 1
+}
+
+_UDEV_DAEMON=`udev_daemon`
+
 udev_enabled() {
-       if [ ! -e /lib/udev/udevd ]; then
-               debug "/lib/udev/udev doesn't exist"
+       if [ -z "$_UDEV_DAEMON" ]; then
+               msg "WARNING: Cannot find the udev daemon; daemon will not be started in initramfs."
                return 1
        fi
 
@@ -14,9 +29,9 @@ udev_enabled() {
 udev_run() {
        mkdir -p /run
 
-       /lib/udev/udevd --daemon > /dev/null
+       $_UDEV_DAEMON --daemon
        udevadm trigger --action=add
        udevadm settle
 
-       killall udevd 2>/dev/null
+       killall `basename $_UDEV_DAEMON` 2>/dev/null
 }
index 45d6592bc39a23f9487de306dc0abdfc7ece7e7f..cbb4a39611ecd8c2fcbe150f58502f5eeb34a00e 100644 (file)
@@ -3,7 +3,7 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 RDEPENDS = "busybox"
 
-PR = "r1"
+PR = "r2"
 
 inherit allarch