]> code.ossystems Code Review - openembedded-core.git/commitdiff
mtools: Patch out a useless sanity check
authorJussi Kukkonen <jussi.kukkonen@intel.com>
Thu, 2 Jun 2016 10:49:32 +0000 (13:49 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 3 Jun 2016 12:12:13 +0000 (13:12 +0100)
The sanity check is ensuring that filesystem size is divisible by
sectors-per-track. That seems to be just an optimization for ancient
media, and quite tricky to accomplish as different dosfstools versions
produce filesystems with different sectors-per-track.

Continue processing even if filesystem size is not divisible by
sectors-per-track.

Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/mtools/mtools/0001-Continue-even-if-fs-size-is-not-divisible-by-sectors.patch [new file with mode: 0644]
meta/recipes-devtools/mtools/mtools_3.9.9.bb
meta/recipes-devtools/mtools/mtools_4.0.18.bb

diff --git a/meta/recipes-devtools/mtools/mtools/0001-Continue-even-if-fs-size-is-not-divisible-by-sectors.patch b/meta/recipes-devtools/mtools/mtools/0001-Continue-even-if-fs-size-is-not-divisible-by-sectors.patch
new file mode 100644 (file)
index 0000000..1f8f835
--- /dev/null
@@ -0,0 +1,34 @@
+From 5cc8d1f96ab6d3459e13631d8356f87381562352 Mon Sep 17 00:00:00 2001
+From: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Date: Thu, 2 Jun 2016 09:49:44 +0300
+Subject: [PATCH] Continue even if fs size is not divisible by
+ sectors-per-track
+
+Filesystem with a size that is not divisible by sectors-per-track is
+not broken or invalid: it might be unoptimized on media where
+heads and cylinders actually matter but that should be it.
+
+Preserve the warning but make mtools continue even if fs size is not
+divisible by sectors-per-track.
+
+Upstream-Status: Submitted [info-mtools@gnu.org]
+Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
+---
+ init.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/init.c b/init.c
+index c9152e0..4e16a01 100644
+--- a/init.c
++++ b/init.c
+@@ -338,7 +338,6 @@ Stream_t *fs_init(char drive, int mode, int *isRop)
+               fprintf(stderr,
+                       "Add mtools_skip_check=1 to your .mtoolsrc file "
+                       "to skip this test\n");
+-              exit(1);
+       }
+       /* full cylinder buffering */
+-- 
+2.1.4
+
index 3423917d004f1586c10374ad7eed8ae8f650475a..2904ff4f9845cf5a4720099089e48d461d69e9f2 100644 (file)
@@ -33,7 +33,9 @@ SRC_URI = "http://downloads.yoctoproject.org/mirror/sources/mtools-${PV}.tar.gz
            file://mtools-makeinfo.patch \
            file://mtools.patch \
            file://no-x11.patch \
-           file://fix-broken-lz.patch"
+           file://fix-broken-lz.patch \
+           file://0001-Continue-even-if-fs-size-is-not-divisible-by-sectors.patch \
+           "
 
 inherit autotools texinfo
 
index efde547e263b2379e34592bc77d025648500cb27..b0efc9ecfe5439d5d80e994c97bf6abaacdb8f14 100644 (file)
@@ -29,7 +29,9 @@ SRC_URI[sha256sum] = "59e9cf80885399c4f229e5d87e49c0c2bfeec044e1386d59fcd0b0aead
 
 SRC_URI = "${GNU_MIRROR}/mtools/mtools-${PV}.tar.bz2 \
            file://mtools-makeinfo.patch \
-           file://no-x11.gplv3.patch"
+           file://no-x11.gplv3.patch \
+           file://0001-Continue-even-if-fs-size-is-not-divisible-by-sectors.patch \
+           "
 
 
 inherit autotools texinfo