]> code.ossystems Code Review - openembedded-core.git/commitdiff
libcap: avoid losing default Large File Support CFLAGS
authorAndre McCurdy <armccurdy@gmail.com>
Thu, 16 Jul 2015 01:58:07 +0000 (18:58 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 20 Jul 2015 09:38:59 +0000 (10:38 +0100)
-D_LARGEFILE64_SOURCE and -D_FILE_OFFSET_BITS=64 are present in the
default libcap CFLAGS. Add them to the OE CFLAGS too, so that they
are still in effect when the OE CFLAGS over-ride the defaults.

Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-support/libcap/libcap_2.24.bb

index e8ae7ce9ab8cb0403d5fb691030b8f4f2fa11827..161bb702c33cdce7d5dc2a27a49da9cd34bec737 100644 (file)
@@ -41,6 +41,9 @@ EXTRA_OEMAKE = " \
 
 EXTRA_OEMAKE_append_class-target = " SYSTEM_HEADERS=${STAGING_INCDIR}"
 
+# these are present in the libcap defaults, so include in our CFLAGS too
+CFLAGS += "-D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
+
 do_compile() {
        oe_runmake ${EXTRA_OECONF}
 }