]> code.ossystems Code Review - openembedded-core.git/commitdiff
eglibc: fix packaging of some of nativesdk packages
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Wed, 21 Sep 2011 18:39:58 +0000 (22:39 +0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 22 Sep 2011 07:47:22 +0000 (08:47 +0100)
eglibc.inc contains packaging rules that depend on PKGSUFFIX expansion.
However that variable wasn't expanded properly in some case. E.g.

PACKAGES = " ... nscd${PKGSUFFIX} ..."
FILES_nscd${PKGSUFFIX} = "${sbindir}/nscd*"

would be expanded to

PACKAGES = " ... nscd-nativesdk ..."
FILES_nscd = "${sbindir}/nscd*"

Thus leading to empty -nativesdk packages and missing files. To overcome
that use python code blob to properly define PKGSUFFIX variable.

Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/eglibc/eglibc-locale.inc
meta/recipes-core/eglibc/eglibc-package.inc
meta/recipes-core/eglibc/eglibc_2.12.bb
meta/recipes-core/eglibc/eglibc_2.13.bb

index 9424ff577ae65083666a80b99f40e2a935276154..cfc7d84eb9b96c898508cb3296a4c95fa165ac61 100644 (file)
@@ -26,10 +26,15 @@ BINARY_LOCALE_ARCHES ?= "arm.* i[3-6]86 x86_64 powerpc mips"
 # set "0" for qemu emulation of native localedef for locale generation
 LOCALE_GENERATION_WITH_CROSS-LOCALEDEF = "1"
 
-PR = "r16"
-
-PKGSUFFIX = ""
-PKGSUFFIX_virtclass-nativesdk = "-nativesdk"
+PR = "r17"
+
+python __anonymous () {
+    import bb
+    if bb.data.inherits_class("nativesdk", d):
+        bb.data.setVar("PKGSUFFIX", "-nativesdk", d)
+    else:
+        bb.data.setVar("PKGSUFFIX", "", d)
+}
 
 PROVIDES = "virtual/libc-locale${PKGSUFFIX}"
 
index 519a49c75fd35e946f51deffd69f50acf1ae0296..dc6fce0442c0497b7554c59097d9fab176a43367 100644 (file)
@@ -17,8 +17,13 @@ python __anonymous () {
 # Set this to zero if you don't want ldconfig in the output package
 USE_LDCONFIG ?= "1"
 
-PKGSUFFIX = ""
-PKGSUFFIX_virtclass-nativesdk = "-nativesdk"
+python __anonymous () {
+    import bb
+    if bb.data.inherits_class("nativesdk", d):
+        bb.data.setVar("PKGSUFFIX", "-nativesdk", d)
+    else:
+        bb.data.setVar("PKGSUFFIX", "", d)
+}
 
 PACKAGES = "${PN}-dbg ${PN} catchsegv${PKGSUFFIX} sln${PKGSUFFIX} nscd${PKGSUFFIX} ldd${PKGSUFFIX} ${PN}-utils eglibc-extra-nss${PKGSUFFIX} eglibc-thread-db${PKGSUFFIX} ${PN}-pic ${PN}-dev ${PN}-doc libcidn${PKGSUFFIX} libmemusage${PKGSUFFIX} libsegfault${PKGSUFFIX} ${PN}-pcprofile libsotruss${PKGSUFFIX}"
 
index a9d208b7565414fe65516e3c4a325dd273dc2550..7a1a5695fea7cc55e6d332f05113d3171d90ea4a 100644 (file)
@@ -1,7 +1,7 @@
 require eglibc.inc
 
 DEPENDS += "gperf-native"
-PR = "r24"
+PR = "r25"
 
 SRCREV = "14158"
 
index b549496c26a2f4fac0523c591f4bc4952168f90c..e172785c693afc381b9cd6d7b9b9ef4405b59305 100644 (file)
@@ -3,7 +3,7 @@ require eglibc.inc
 SRCREV = "14157"
 
 DEPENDS += "gperf-native"
-PR = "r15"
+PR = "r16"
 PR_append = "+svnr${SRCPV}"
 
 EGLIBC_BRANCH="eglibc-2_13"