]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add ross's libgtkstylus
authorChris Lord <chris@openedhand.com>
Fri, 9 Sep 2005 13:52:55 +0000 (13:52 +0000)
committerChris Lord <chris@openedhand.com>
Fri, 9 Sep 2005 13:52:55 +0000 (13:52 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky@20 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/libgtkstylus/files/gtkstylus.sh [new file with mode: 0644]
openembedded/packages/libgtkstylus/files/makefile.patch [new file with mode: 0644]
openembedded/packages/libgtkstylus/libgtkstylus_0.4.bb [new file with mode: 0644]

diff --git a/openembedded/packages/libgtkstylus/files/gtkstylus.sh b/openembedded/packages/libgtkstylus/files/gtkstylus.sh
new file mode 100644 (file)
index 0000000..b1302ed
--- /dev/null
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+GTK_MODULES=libgtkstylus.so
+
+export GTK_MODULES
diff --git a/openembedded/packages/libgtkstylus/files/makefile.patch b/openembedded/packages/libgtkstylus/files/makefile.patch
new file mode 100644 (file)
index 0000000..fadea69
--- /dev/null
@@ -0,0 +1,11 @@
+--- libgtkstylus-0.3/Makefile.am.old   2005-01-16 15:56:07.000000000 +0000
++++ libgtkstylus-0.3/Makefile.am       2005-01-16 15:56:08.000000000 +0000
+@@ -3,7 +3,7 @@
+ module_LTLIBRARIES = libgtkstylus.la
+ INCLUDES = @STYLUS_CFLAGS@
+-LDADD = @STYLUS_LIBS@
++LIBS = @STYLUS_LIBS@
+ libgtkstylus_la_SOURCES = tap.c
diff --git a/openembedded/packages/libgtkstylus/libgtkstylus_0.4.bb b/openembedded/packages/libgtkstylus/libgtkstylus_0.4.bb
new file mode 100644 (file)
index 0000000..fc03d44
--- /dev/null
@@ -0,0 +1,18 @@
+DESCRIPTION = "GTK plugin for stylus based systems"
+SECTION = "libs"
+MAINTAINER = "Chris Lord <chris@openedhand.com>"
+DEPENDS = "gtk+"
+LICENSE = "LGPL"
+FILES_${PN} = "/etc ${libdir}/gtk-2.0"
+
+inherit autotools
+
+SRC_URI = "http://burtonini.com/temp/${PN}-${PV}.tar.bz2 \
+       file://makefile.patch;patch=1 \
+       file://gtkstylus.sh"
+
+do_install_append() {
+       install -d ${D}/${sysconfdir}/X11/Xsession.d
+       install -m 755 ${WORKDIR}/gtkstylus.sh ${D}/${sysconfdir}/X11/Xsession.d/45gtkstylus
+}
+