]> code.ossystems Code Review - openembedded-core.git/commitdiff
patchelf: upgrade 0.13 -> 0.14.1
authorwangmy <wangmy@fujitsu.com>
Mon, 29 Nov 2021 15:00:54 +0000 (23:00 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 1 Dec 2021 16:22:07 +0000 (16:22 +0000)
refresh handle-read-only-files.patch

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/patchelf/patchelf/handle-read-only-files.patch
meta/recipes-devtools/patchelf/patchelf_0.14.1.bb [moved from meta/recipes-devtools/patchelf/patchelf_0.13.bb with 91% similarity]

index 63080a42d444dd72f1747661b92e29f782d34bd7..8d9a50a69792c8cc10e6aa7339c041c4b9a66cb7 100644 (file)
@@ -15,10 +15,10 @@ Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
  1 file changed, 15 insertions(+), 1 deletion(-)
 
 diff --git a/src/patchelf.cc b/src/patchelf.cc
-index fd1e7b7..a941da1 100644
+index 1aeae88..6b77afe 100644
 --- a/src/patchelf.cc
 +++ b/src/patchelf.cc
-@@ -527,9 +527,19 @@ void ElfFile<ElfFileParamNames>::sortShdrs()
+@@ -534,9 +534,19 @@ void ElfFile<ElfFileParamNames>::sortShdrs()
  
  static void writeFile(const std::string & fileName, const FileContents & contents)
  {
@@ -39,10 +39,10 @@ index fd1e7b7..a941da1 100644
      if (fd == -1)
          error("open");
  
-@@ -543,6 +553,10 @@ static void writeFile(const std::string & fileName, const FileContents & content
-     if (close(fd) != 0)
-         error("close");
+@@ -564,6 +574,10 @@ static void writeFile(const std::string & fileName, const FileContents & content
+     if (errno == EINTR)
+         return;
+     error("close");
 +
 +    if (chmod(fileName.c_str(), st.st_mode) != 0)
 +        error("chmod");
@@ -50,3 +50,6 @@ index fd1e7b7..a941da1 100644
  }
  
  
+-- 
+2.25.1
+
similarity index 91%
rename from meta/recipes-devtools/patchelf/patchelf_0.13.bb
rename to meta/recipes-devtools/patchelf/patchelf_0.14.1.bb
index b24c74a1492b58af9417f092488d771837ed6fce..2b63fbfbc3f6295ff5c2723554456c6e1d0fedb8 100644 (file)
@@ -7,7 +7,7 @@ LICENSE = "GPLv3"
 SRC_URI = "git://github.com/NixOS/patchelf;protocol=https;branch=master \
            file://handle-read-only-files.patch \
            "
-SRCREV = "a949ff23315bbb5863627c4655fe216ecbf341a2"
+SRCREV = "8f7b4a7a3648970fe55824cfee2afd3808626a3f"
 
 S = "${WORKDIR}/git"