]> code.ossystems Code Review - openembedded-core.git/commitdiff
unzip: Avoid stripping binaries
authorMark Hatle <mark.hatle@windriver.com>
Mon, 20 Jun 2011 18:23:49 +0000 (13:23 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 23 Jun 2011 10:55:12 +0000 (11:55 +0100)
Not only do we have to override things on the make line, but we
need to hack on configure as well to avoid certain behavior.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-extended/unzip/unzip/avoid-strip.patch [new file with mode: 0644]
meta/recipes-extended/unzip/unzip_6.0.bb

diff --git a/meta/recipes-extended/unzip/unzip/avoid-strip.patch b/meta/recipes-extended/unzip/unzip/avoid-strip.patch
new file mode 100644 (file)
index 0000000..0ef6363
--- /dev/null
@@ -0,0 +1,48 @@
+unix/Makefile: remove hard coded strip commands
+
+Remove the hard coded strip commands, both LF2 (used in linking) and
+STRIP used alone.
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+
+diff -ur unzip60.orig/unix/configure unzip60/unix/configure
+--- unzip60.orig/unix/configure        2009-04-16 14:25:12.000000000 -0500
++++ unzip60/unix/configure     2011-06-21 11:23:36.822849960 -0500
+@@ -17,7 +17,7 @@
+ IZ_BZIP2=${3}
+ CFLAGS="${CFLAGS} -I. -DUNIX"
+ LFLAGS1=""
+-LFLAGS2="-s"
++LFLAGS2=""
+ LN="ln -s"
+ CFLAGS_OPT=''
+diff -ur unzip60.orig/unix/Makefile unzip60/unix/Makefile
+--- unzip60.orig/unix/Makefile 2009-01-18 16:41:18.000000000 -0600
++++ unzip60/unix/Makefile      2011-06-21 11:12:22.900003388 -0500
+@@ -52,7 +52,7 @@
+ CF = $(CFLAGS) $(CF_NOOPT)
+ LFLAGS1 =
+ LF = -o unzip$E $(LFLAGS1)
+-LF2 = -s
++LF2 = 
+ # UnZipSFX flags
+ SL = -o unzipsfx$E $(LFLAGS1)
+@@ -70,7 +70,7 @@
+ CHMOD = chmod
+ BINPERMS = 755
+ MANPERMS = 644
+-STRIP = strip
++STRIP =
+ E =
+ O = .o
+ M = unix
+@@ -776,7 +776,6 @@
+ #
+ gcc:          unix_make
+       $(MAKE) unzips CC=gcc LD=gcc CFLAGS="-O3" LF2=""
+-      $(STRIP) $(UNZIPS)
+ # Heurikon HK68 (68010), UniPlus+ System V 5.0, Green Hills C-68000
+ hk68:         unix_make
index ccdd372cc4b99535e79a47e34eda1e25e598ca9d..b9eff435b1ebbc566db9fd2a65bbf80e0d2f37f0 100644 (file)
@@ -4,14 +4,17 @@ SECTION = "console/utils"
 LICENSE = "Info-ZIP"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=94caec5a51ef55ef711ee4e8b1c69e29"
 PE = "1"
-PR = "r0"
+PR = "r1"
 
-SRC_URI = "ftp://ftp.info-zip.org/pub/infozip/src/unzip60.tgz"
+SRC_URI = "ftp://ftp.info-zip.org/pub/infozip/src/unzip60.tgz \
+       file://avoid-strip.patch"
 
 SRC_URI[md5sum] = "62b490407489521db863b523a7f86375"
 SRC_URI[sha256sum] = "036d96991646d0449ed0aa952e4fbe21b476ce994abc276e49d30e686708bd37"
 S = "${WORKDIR}/unzip60"
 
+EXTRA_OEMAKE += "STRIP=true LF2=''"
+
 export LD = "${CC}"
 LD_virtclass-native = "${CC}"