]> code.ossystems Code Review - openembedded-core.git/commitdiff
mdadm: fix build on qemumips64
authorRobert Yang <liezhi.yang@windriver.com>
Sun, 26 Jan 2014 09:14:54 +0000 (17:14 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 2 Feb 2014 11:21:55 +0000 (11:21 +0000)
The mips64 uses long long for u64 in the kernel, but powerpc's asm/types.h
prevents 64-bit userland from seeing this definition, instead defaulting to u64
== long in userspace. Define __SANE_USERSPACE_TYPES__ to get int-ll64.h
included.

We had a similar fix on ppc64, use it for mips64 will fix the problem.

[YOCTO #5758]

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/mdadm/mdadm_3.3.bb

index cfb9ccd5c39e806ac69ed8ac8522f8005d676847..596b04ded8c369fbbaa4673db1145f4270f05d7c 100644 (file)
@@ -25,11 +25,12 @@ do_configure_prepend () {
 }
 
 EXTRA_OEMAKE = "CHECK_RUN_DIR=0"
-# PPC64 uses long long for u64 in the kernel, but powerpc's asm/types.h
+# PPC64 and MIPS64 uses long long for u64 in the kernel, but powerpc's asm/types.h
 # prevents 64-bit userland from seeing this definition, instead defaulting
 # to u64 == long in userspace. Define __SANE_USERSPACE_TYPES__ to get
 # int-ll64.h included
 EXTRA_OEMAKE_append_powerpc64 = ' CFLAGS=-D__SANE_USERSPACE_TYPES__'
+EXTRA_OEMAKE_append_mips64 = ' CFLAGS=-D__SANE_USERSPACE_TYPES__'
 
 do_compile() {
        oe_runmake