]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto: allow multiple BSPs per branch
authorBruce Ashfield <bruce.ashfield@windriver.com>
Mon, 24 Jan 2011 16:54:32 +0000 (11:54 -0500)
committerSaul Wold <sgw@linux.intel.com>
Mon, 24 Jan 2011 22:42:55 +0000 (14:42 -0800)
By default the linux-yocto recipes operate on the current branch
and use it as a trigger to locate the description of a board. This
model works well when using the git repo outside of a build system
since the commands can be simply invoked and will do something
useful. However, it does mean that you can't have two BSPs that
differ only by configuration, building out of a single branch
in the repository.

This means that you must have many branches for very similar
BSPs. This model is still preferred, but having the choice of
branching strategies is better.

With this change we can have multiple BSPs using a single branch
with the preferred description being hinted from the build
system by passing the $machine value to updateme/configme.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
meta/classes/kernel-yocto.bbclass
meta/conf/distro/include/poky-default-revisions.inc
meta/recipes-kernel/kern-tools/kern-tools-native_git.bb

index 32d2e20a71bc9e0ea0224b315580926f5c141b4a..8479b395cdf9bcb992a3b5a8b0ae1468b91e23b4 100644 (file)
@@ -74,7 +74,7 @@ do_patch() {
        if [ -n "${KERNEL_FEATURES}" ]; then
               addon_features="--features ${KERNEL_FEATURES}"
        fi
-       updateme ${addon_features} ${ARCH} ${WORKDIR}
+       updateme ${addon_features} ${ARCH} ${MACHINE} ${WORKDIR}
        if [ $? -ne 0 ]; then
                echo "ERROR. Could not update ${kbranch}"
                exit 1
@@ -126,7 +126,7 @@ do_kernel_configme() {
        echo "[INFO] doing kernel configme"
 
        cd ${S}
-       configme --reconfig --output ${B}
+       configme --reconfig --output ${B} ${KBRANCH} ${MACHINE}
        if [ $? -ne 0 ]; then
                echo "ERROR. Could not configure ${KMACHINE}-${LINUX_KERNEL_TYPE}"
                exit 1
index e73c971b3324a0e04686162aefa04719bec5c8ae..b9602eafafb2a4f8b09d24fa4682b79555382850 100644 (file)
@@ -57,7 +57,7 @@ SRCREV_pn-gypsy ??= "147"
 SRCREV_pn-inputproto ??= "7203036522ba9d4b224d282d6afc2d0b947711ee"
 SRCREV_pn-inputproto-native ??= "7203036522ba9d4b224d282d6afc2d0b947711ee"
 SRCREV_pn-inputproto-nativesdk ??= "7203036522ba9d4b224d282d6afc2d0b947711ee"
-SRCREV_pn-kern-tools-native ??= "f553af044615ba75c2b4b7ef1f382e6f75087213"
+SRCREV_pn-kern-tools-native ??= "8832b75dc2e494ae96ca3e1dee7bfde2f3096904"
 SRCREV_pn-libdrm ??= "3f3c5be6f908272199ccf53f108b1124bfe0a00e"
 SRCREV_pn-libfakekey ??= "2031"
 SRCREV_pn-libgdbus ??= "aeab6e3c0185b271ca343b439470491b99cc587f"
index 7350746b8cb45f7c1160dec9f3277fb9fff91d7d..58e64709f23f5db16ae904f584c079fbb0686d6c 100644 (file)
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=e2bf4415f3d8
 
 DEPENDS = "git-native guilt-native"
 
-PR = r8
+PR = r9
 PV = "0.1+git${SRCPV}"
 
 inherit native